Jump to content
Corsair Community

Serious... Headset sound problem again


Recommended Posts

Right, I'm seriously pissed off.


First off, I had this problem a month ago and fixed it by deleting all my Realtek stuff then it worked. Problem now is I have no Realtek drivers and it doesn't work. I have distorted and missing sound and it's just awful and impossible to use. This was after I done the most recent Firmware Update, is there any chance to get the old Firmware back as it seemed to work fine?


Secondly, I only updated my Firmware because of an annoying beeping sounds that would happen every two seconds and no matter what I did, it would not go, I was on 70% battery, connection was fine, everything was fine just it kept beeping. Is this a way for Corsair to tell people to update there Firmware? I don't know. Can someone give me some answers to these questions cause I'm seriously thinking about returning them.


Below is a link to my old thread, it might help:




Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...