Jump to content
Corsair Community

Corsair Void wireless mic not working


Recommended Posts



I just bought a Corsair Void wireless. And I have installed CUE, updated firmware etc.

But the mic on my brand new headset is not receiving any sound.

It is my standard input device.

The mic did not work when I first plugged in the headset either, before I installed the software.


Otherwise my headset seems to be working fine, sound, lights, wireless etc.


I have clean installed drivers/software twice. Tried my girlfriends + my old computer.


Can anyone point me to what might be the problem?

To me it sounds like a hardware error.

But maybe I have overlooked something?


Br, Tett

Link to comment
Share on other sites

Could be a headset issue if it never worked in the first place.


Double check the microphone is not muted and sidetone is fully maxed, then try talking. Can you hear yourself? Have you tried reflashing the firmware by force flashing it via CUE?

Link to comment
Share on other sites

Thanks for your fast response.

I have tried to listen to the mic with sidetone, ts3, mumble & windows. All I hear is a low buzzing when maxxed, tapping the mic does affect the buzzing at all.


I have reflashed the firmware several times.


I think you are right, some factory defect or something.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...