Jump to content
Corsair Community

Corsair Utility Engine stuck in 3d mode


Recommended Posts

Hi, i've noticed this problem/bug from day one.


i have my GPU clock speeds setup in separate profiles. while in desktop browsing mode, it's set to the default factory clock speed, and while a game is launched, it automatically switches to a higher overclocked speed. all this is done through MSI afterburner's 2d/3d profile within.


i've noticed from day one since i got my Corsair K65 RGB that whenever the Corsair Utility Engine is running in the background, the GPU profile is stuck in 3d mode. i've seen this behavior in some programs in the past. so it know it's program specific and sometimes developers misses this. the trouble is, i need the Corsair Utility engine to run my K65 RGB correctly. i tried setting up different keyboard profiles without the Utility Engine and none will work without the engine running in the background. soon as the Utility Engine is shut down, the GPU correctly switches back to 2d mode.


i would like to stick with this Keyboard, but this issue is having me thinking of selling the keyboard and get the Razer Chroma instead. i have other razer keyboards and the razer synopsis program doesn't do this.


also, i can confirm that this happens with both ATI and Nvidia GPUs.


can someone from the dev team at least acknowledge this and let us know that it'll be fixed? thanks


windows 7 64bit with Utility Engine 1.15.36 and latest keyboard firmware

Link to comment
Share on other sites

Could you list the GPUs that experiences this issue. Also how old is your windows 7 install, have you tried on another system, does this happen with other OC software.


it's the most current up to date windows 7 64bit.


happened on both 290x, 290x crossfire, and 980ti.


i've seen this happen before with some software that triggers the 3d mode.


i use MSI Afterburner, latest 4.2 version. haven't used other OC software as Afterburner is pretty much the industry standard and preferred OC software.


some of the softwares that i noticed in the past that would trigger the 3d mode are some older versions of HWinfo, ATI Crimson 15.12 (although after countless bug report, ATI later addressed this issue in Crimson 16.1 so the QT backend doesn't trigger 3d mode anymore).


i am not a dev, but i know that certain programs are written in a way that somehow uses or triggers high performance 3d mode. this needs to be avoided.

Link to comment
Share on other sites

also i should also mention that Corsair link has this same exact issue as well. it's like both are written with the same programming and both triggers the 3d mode. i don't use Corsair Link so it never really bothered me. i only installed it a few times in the past to change the RGB lighting on my H110GTX. but none the less, i hope it helps to point out that both Link and Utility Engine suffers the same problem.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...