Jump to content
Corsair Community

Slow RAID 0 Read Speed


Technogod

Recommended Posts

I have two Corsair Neutron 256GB SSD's in a RAID 0 configuration. Refer to my profile for hardware configuration. I've run multiple benchmarks and my sequential read speed is 390 MB/s and my sequential write speed is 803 MB/s. Why is my read speed so much slower?

 

Intel RST Driver 11.7.0.1013

Data Stripe Size 16K

Write-back cache enabled

Windows write-cache buffer flushing off

Link to comment
Share on other sites

yes i see,,

seems to me read should be higher but even so it seems as your write speed is too high

id be also interested in seeing this resolved myself

im sure another will pop in and assist.

have you tried other benching progs?

Link to comment
Share on other sites

Have you tried different SATA data cables?

Latest BIOS and chipset drivers?

Were there any background processes running? E.g. anti-virus scans, etc?

 

The last option would be to backup your data and secure erase the SSD with Parted Magic or similar.

 

Note: A secure erase will break your RAID array as well as permanently delete ALL data on the drives.

Link to comment
Share on other sites

I fixed the problem. Problem was the stripe size. Intel RST Utility recommended a 16K stripe size for best performance. This is incorrect. I had always ran a 64K stripe size on my previous RAID arrays. I found 128K gave me the best performance. I'm getting around 800MB/s read and write speeds.
Link to comment
Share on other sites

  • 3 weeks later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...