Jump to content
Corsair Community

M40 Gaming Mouse - having problems installing firmware & settings software!!


Recommended Posts

Can anyone help? I got a Corsair M40 mouse and I've tried to download the "control centre" from corsair's website so i can program some of the buttons, but when i try and install its not recognising that the mouse is plugged in.


Below is the screen i get once i have tried to install.


Can anyone help??:laughing:



Link to comment
Share on other sites

Is the mouse detected in Windows?

Have you tried plugging the mouse in a different USB port and another computer? Is the mouse detected?


Thx for the reply.


i had a play around with changing the usb ports, originally had it plugged into a USB3 port but i plugged the mouse over to a USB2 and all seems to work ok. Not sure whats wrong with that USB3 but i am installing some updates/drivers which should rectify the problem.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...