Jump to content
Corsair Community

Unable to update Corsair Neutron from M306 to M311


Recommended Posts

From your post from the other thread

I am also in this exact boat. it will not update from M306 to M311 using toolbox... my system specs are in my profile. I have been having boot issues and am forced to go into bios everytime and sometimes its not their as well.. corsair said I needed to update firmware. so I ended up here. now this is my primary boot as well. I have windows 8.1 pro x64 installed on it. if I need to whipe it I am ok with that I suppose. but I want to avoid if possible. any help would be wonderful. thanks in advance


If you are experiencing any issues with the SSD, first thing i would recommend is to backup all your important data.


For the firmware update,

-Make sure the SSD is plugged into a Intel SATA port, Try SATA II and see if that helps as well

-Is AHCI enabled in the BIOS

-Have you tried the MSAHCI drivers instead of IRST drivers?

Link to comment
Share on other sites

  • 1 month later...
  • 2 weeks later...


I´m facing the same issue. I have tried with intel RST installed and not installed, have tried another sata port, have tried turn RST ON/OFF in BIOS , always in AHCI mode and everytime toolbox fails to update the firware. Even with all these configurations , toolbox reads the SSD as SCSI fixed disk. What else can i try?


Link to comment
Share on other sites

  • 1 month later...

Using the Corsair SSD Toolbox, both my computers failed to update the firmware on my Neutron 256 GB SSD (CSSD-N256GB3-BK).


I first tried running the Toolbox on my Win 7 desktop, as my Win 8 64-bit HP Envy Laptop was not detecting the SSD while my Win 7 machine could. After the firmware update from M306 failed, I ended up reformatting the drive and trying to install it in the Win 8 machine again. I am not sure why the Win 8 laptop just now started detecting the SSD again (perhaps because I formatted it as MBR rather than GBT).


Anyway, point being, despite the Win 8 machine detecting the SSD, the Toolbox also fails to update the firmware, just as my Win 7 machine did.


Is it possible to update to firmware M311?

Link to comment
Share on other sites

  • 3 weeks later...
  • 6 months later...


This topic is now archived and is closed to further replies.

  • Create New...