The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

 
 
Thread Tools Search this Thread Rating: Thread Rating: 130 votes, 5.00 average. Display Modes
Prev Previous Post   Next Post Next
  #11  
Old 11-24-2014, 06:35 AM
SpeedFreak01 SpeedFreak01 is offline
Registered User
SpeedFreak01's PC Specs
 
Join Date: Oct 2014
Posts: 17
POST ID # = 743341
SpeedFreak01 Reputation: 10
Default

Bit of an update from me, loving the gui so far.
The ability to select colours / patterns and adjust a range of settings is just great. Better yet is the ability to use the brightness button.
Words cant express how happy i am that brightness is now working. Thank you very much :)
Storing profiles and writing them to the hardware seems to work fine as well.

One thing though, the changes you made to ckb-daemon in commit 11ec0b3, stopped the daemon working for me. I ended up checking out commit b37a519, which resolves the issue.

ckb-daemon output
Code:
ckb Corsair Keyboard RGB driver v0.0.3
Setting FPS to 60
Setting default layout: us
Root controller ready at /dev/input/ckb0
Connecting Corsair K95 RGB Gaming Keyboard (S/N: 0701B03EAE3618E3530D5E92F5001946)
The program halts here, and the following is spammed in dmesg
Code:
[ 1754.114238] usb 8-2: usbfs: USBDEVFS_CONTROL failed cmd ckb-daemon rqt 33 rq 9 len 64 ret -110
[ 1754.170184] usb 8-2: usbfs: USBDEVFS_CONTROL failed cmd ckb-daemon rqt 33 rq 9 len 64 ret -110
[ 1754.226127] usb 8-2: usbfs: USBDEVFS_CONTROL failed cmd ckb-daemon rqt 33 rq 9 len 64 ret -110
[ 1754.282073] usb 8-2: usbfs: USBDEVFS_CONTROL failed cmd ckb-daemon rqt 33 rq 9 len 64 ret -110
[ 1754.289059] usb 8-2: usbfs: USBDEVFS_CONTROL failed cmd ckb-daemon rqt 33 rq 9 len 64 ret -110
Guessing this might have something to do with the changes to usb.c?? could be wrong though.

I ended up cherry-picking the two later commits after 11ec0b3, fixed a merge conflict in usb.c where i pretty much removed anything that could set fail to 1 in the setupusb method and now the keyboard connects, and it connects much faster than it use to.

Not exactly sure why this works, but maybe you might see something.

Thanks again :)

Last edited by SpeedFreak01; 11-24-2014 at 06:47 AM.
Reply With Quote


 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 07:01 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.