Jump to content
Corsair Community

Strafe RGB not working!


Recommended Posts

After working perfectly yesterday, I noticed my backspace and a couple other keys were not working so I unplugged and plugged back in, now nothing is working. 

When I plug in there are no sounds to say the computer has recognised the device, nor is anything being detected in iCUE. There are however white lights that come on, but only behind the num, scroll, and caps lock keys. I have tried soft resetting by holding the escape key and fn+f4 etc. Also tried removing certain devices but nothing seems to be working. 

I am under the belief that it needs a firmware update however without iCUE identifying it, I'm struggling to do this. 

Any help appreciated.

Link to comment
Share on other sites

Update: After periodically plugging the keyboard back in, sometimes the computer + iCUE will recognise it however if I force update the firmware, when it reaches 100%, the windows sound will play and the keyboard will no longer be recognised. 

On a couple of occasions I have managed to get it back to the point where it is working minus the backspace key and a few others, but only temporarily before it gets disconnected again.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...