Jump to content
Corsair Community

No RGB Lighting on Keyboard when iCue is running


pjs37
 Share

Recommended Posts

So I am having an annoying issue that came out of no where.  My K70 RGB Keyboard (non-mk2) suddenly decided it not long wants to do whatever iCue tells it. When iCue is running it just stays off.  When iCue is off it turns red with a few keys white.  I tried resetting the keyboard.  Tried Re-installing the firmware.  Tried to re-install iCue. Uninstalled the motherboard RGB software (Gigabyte Fusion); Disabled Wallpaper Engine and its tie-ins.  I powered off my PC unplugged it hit the power switch to drain the capacitors.  I tried moving it to different USB ports.  Nothing same exact behavior.  I do not have any MSI RGB software installed which is the only topic I kept seeing pop up specific to this issue.  I am truely stumped at this point.  Any idea?  All the other RGB is working as expected with no issue just the keyboard having the issue. It was working a few weeks ago.

Windows 10; Ryzen 3800X; Aorus X570 Elite Master Wifi; 32gb Corsair Vengeance Memory with RGB; H115i Pro; Commander Pro; Lighting Node with 4 LED Strips MM800 Mouse Pad and a Razer Mamba Elite.

Link to comment
Share on other sites

So I plugged the keyboard into my laptop and installed iCue 4 and everything worked as expected so hardware-wise I think the keyboard is ok.  I can only imagine its some weird software conflict going on at this point.  I may just re-install my OS and try and move to Windows 11 soon and this may fix this issue along with other issues.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...