Jump to content
Corsair Community

SSD disappears after restarting Windows


Recommended Posts

Hello everyone,


I own a MSI laptop (MSI GL62 6QD) and I have recently bought a new SSD in order to upgrade it. The SSD is the Corsair Force MP510 480 GB. The laptop has a slot prepared for the SSD, so no problem with installing it. When I tried to clone the system (Windows 10 - 64 bits) from the hard drive to the SSD, the program I used (MiniTool Partition Wizard) restarted the system in order to do so, but then it said that there was some change that made not possible for the cloning to proceed. I then realized that the SSD had disappeared from the system: it didn't appear neither in the MiniTool Partition Wizard, nor the disk management of Windows, nor the BIOS. After trying several things I concluded that the SSD appears when I start the system for the first time, but it disappears after restarting the system. It reappears only after turning off and on the system.


I browsed the forum and found a thread that described this same problem, the thing is that the thread is from 2013... https://forum.corsair.com/v3/showthread.php?t=124501


Some people mentioned a bug of the firmware version, but given the case that it is a thread from 2013 I highly doubt that it could be the same issue again... or could it be? I attach a image showing that the SSD has the latest firmware version.


Thanks in advance.


Link to comment
Share on other sites

I have had the same issue with my 1tb MP510,


I got it a week or so ago and I've ripped it out of my PC countless times and tried it on PCIe to m.2 adaptors, m.2 slots on my board, it works fine normally but as soon as I run a game or any other program from that drive it gives a write error and then no app can write to the drive, I restart the PC and the drive is gone entirely including from the bios e.t.c. then another restart or 2 and its back and acting like nothing ever happened until I use it again, i can download files and install to the drive but once I run anything on the drive regardless of what it is it gives up and starts all over again.


I've actually broken my PCIe extender for vertical mounting my GPU because I've had it in and out so much in the last few days diagnosing the issue. just contacted scan about a replacement or refund but if its going to be a common fault ill pay the extra for a samsung ssd that should be more reliable.

Link to comment
Share on other sites

Hi DeadpoolUK.


What computer do you have? I actually haven't been able to run anything on the SSD, because when I try to clone the HDD to the SSD, the program I use restarts the system before starting to do so, and it is after restarting the system when the SSD disappears, so I can't complete the process in order to be able to run anything on the SSD. I have thought about running it in Safe Mode, but in order to enable the Safe Mode I have to restart, so same issue again.


I contacted Corsair's support and they told me to format the SSD through the Disk Management, but nothing changed, so the next thing they told me was to request an exchange for the SSD, but I'm not sure whether that will solve anything or if I will find the same problem again. I might start thinking about buying a different brand of PCIe SSD or even buy a SATA SSD and install it instead of the DVD drive, but it would be a shame if I'm not able to take advantage of the PCIe slot.

Link to comment
Share on other sites

  • 10 months later...
  • Create New...