Jump to content
Corsair Community

Void Pro Wireless Headset not connecting


HedgehogKS
 Share

Recommended Posts

Hello people, i'm having a bit of a headache with my wireless headset.

 

Yesterday i was using it normally, turned it off, went to sleep. Today it won't turn on.

 

I tried connecting it with it's USB cable, no response (the little LED indicator doesn't work either)

I tried force-updating firmware, CUE tells me to connect to USB, i do that and it doesn't work, cancelled update at 0%

According to what i read in these forums it's not in bootloader mode.

 

I tested the USB cable with my phone, it works normally.

I tried re-pairing with the USB dongle.

Reinstalling CUE didn't work either.

CUE shows "Not connected" on the status/battery line.

 

Battery was charged yesterday, so i highly doubt it's a drained battery case.

 

I read there's a way to get corsair employees to send repair files for these cases. Is that whay i need? How do i get in contact? Am i missing something?

 

Please help! Losing my wireless headset feels like the car breaking down and having to go back to public transport! :bigeyes:

Link to comment
Share on other sites

 Share

×
×
  • Create New...