Jump to content
Corsair Community

Holy smoking MOBOs Batman!


Recommended Posts

TL;DR Moron has installed a new PSU, did he do it right?







Morning all, I'll preface this with I'm not much of a hardware guy. I've been learning as I've been going with help from a few friends and as I'm swapping out part or upgrading parts from my PC I've been getting educated.


So I was replacing my old HX450 PSU with the RM750 and it's my first PSU change. As far as I could tell everything was fine booted up and nothing was getting power so I had a sleep on it. Tried again in the morning, the fan on the graphics card went nuts fast and there's smoke coming from my MOBO but everything now had power looks like the first bother was a loose connection.


Currently everything seems to be getting power but I'm getting nothing on screen.



So I'm here now to check this isn't me just doing something glaringly obviously wrong.


Started out with the SATA, seemed simple PCI-E to SATA cable, plugged in in the Perif./Sata port of the PSU and the HDDs.


PCI-E in on the graphics card, PSU came with a cable labeled Type-3 and PCI-E at the other end so I went with that (It did split off into two PCI-E connections).



So what was previously hard wired into my old PSU was a large 24 pin and a smaller one with two sets of four (1)(2) both to different parts of the MOBO. 24 pin was obvious I thought.


One large 24 pin port on the MOBO and the cable split in two hitting the PSU in the bottom right.


For the one headed to the other part of the MOBO which is near where the smoke seemed to be coming from I ran a cable labelled Type-3 to CPU which was the only one which seemed to fit in the port (ATX 12v?).


Edit: CPU and from what I can see of the MOBO aren't showing any signs of damage. No marks or burns.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...