Jump to content
Corsair Community

Corsair XMS3 only gives half of what its supposed to.


Recommended Posts

Hello people!


First of all id like to say i am a complete tool when it comes to computers but please try and understand me.


I have a problem with memory on my computer yeah. I have 2 corsair xms3 2x2 gb ddr3 1333 mhz sticks that i have had for about 2 years now. The past year i have been out of my country and didnt use my pc for all that time. So when i came back some weeks ago my motherboard didnt wanna work anymore so i bought a new motherboard and cpu. Everything works great except the memories. A year ago they showed the correct amount of memory which would be 8 gb. Now they just show half of that (2048 mb each according to cpu-z). Funny enough my dad has the exact same kind of memories, xms 3 2x2 gb that he bought not more than 2 months ago and those memories do the same thing. They only show half of what they are supposed to. I tried his memories in my pc and vice versa but still the same result. Also i did add 2 older memories to the other 2 slots on the motherboard and they show the correct amount so its definitely something with the corsair memories.. right?


I should add that i have windows 7 64 on my machine.


Somebody has any idea what is going on?


Thank you so much in advance!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...