Jump to content
Corsair Community

Issues with Corsair Link and Windows 8.1


Recommended Posts

I have the entire Link system minus a power supply. I got this unit when I was using windows 7. It worked fine aside from some minor bugs. Ever since I upgraded to windows 8 and eventually 8.1 and upgrading the FW on the Commander and all the devices, everything has been going downhill. There are problems all over the place and seem to be multiplying. I contacted tech support but they said it was the new usb settings in Windows 8 and 8.1. I tried the regedit solution but I was unable to find VID_1B1C&PID_0C04. I am not sure if this is specific to the Hydro coolers connected directly into the motherboard since mine is attached to the Commander. My current list of problems which started to manifest after the upgrade to Windows 8 and then 8.1 are the following:


1.) The Link Commander shuts down when my system is powered down(LEDs on the commander are off) and I have to turn off the power supply and turn it back on to turn the Commander back on.


2.) Sometimes even if the Commander is on, everything connected to the Commander does not show up in the Link SW. I have to shut down and turn off the power supply and turn it back on to get the the devices attached to the Commander to show up in Link.


3.) LEDs on my H80i are malfunctioning. It started with the red LED. As long as I played with the sliders I could get it to turn on but if I turned off the red LED or switched to another colour the red LED would not come back on unless I played with it again. Recently the red LED stopped working altogether and the blue LED started flickering and eventually stopped working. (I have RMAed this unit and I am currently awaiting my replacement.)


4.) The memory temperature on the Link SW 2.6.5124 does not correspond to the LEDs on the Airflow Pro. When I went back to a previous version of the Link SW to upgrade some firmware, it started showing temperatures that corresponded to the LEDs.


5.) The dial on the Corsair 600T also does not show up on the current Link SW. Again when I went back to a previous version of the Link SW to upgrade some firmware, it showed up but it did not work.


6.) I have had the H80i with a previous FW and Link SW just disconnect and stop working completely while the computer was running. A simple reboot fixed the issue and it hasn't happened since I have upgraded the FW and SW.


I am currently running Windows 8.1 Pro. I have an Asus Rampage 2 Extreme motherboard. I have every Link device minus a PSU. I have a fresh copy of Windows and the firmware is up to date on all devices. I am running the latest Link SW. I have tried everything I could think of and this device continuously mocks me. I really hate to pull it out of my system because it's everything I have dreamed of in terms of a fan controller, but at this point it has become more trouble than it's worth.


I was wondering if anyone else has had these issues and if anyone has found any sort of solution to them because I has exhausted everything I could think of. I don't know what the problem is at this point. I am not sure if it's the FW on the Link devices causing the whole thing to malfunction(referring to when I first got the unit it completely did not work because the H80i FW was not upgraded), the Link SW, Windows 8.1, my motherboard or any combination of the four.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...