View Single Post
  #309  
Old 10-08-2019, 10:18 AM
Atralbus Atralbus is offline
Registered User
 
Join Date: Oct 2019
Posts: 1
POST ID # = 1020678
Atralbus Reputation: 10
Default

I can confirm this is still an issue with the latest version of iCUE. I contacted with the customer support and this is the only response I got:

Quote:
There are some compatibility issues with X79 chipset and iCUE. If you have the latest bios and the latest chipset drivers installed, I'm afraid we have tried all the troubleshooting steps.
There are hundreds of reports about the issue but I guess you can't even reproduce it. I paid $150 on a keyboard and only later I learn that there is a software compatibility issue with this chipset. I don't even mention about 2 months I spent on investigating the cause of the issue, desperately. I bought a new PSU for no reason thinking that it was the cause. The biggest problem here, we do not get any warning, log in the system that could give us some hint.

Now, I assume that you don't want to waste any more resource on this issue since it's not affecting a lot of customers. But at least put some compatibility information or announcement in your website about it. Announce that you accept the issue and you are not able to solve it.

You can be sure I'm not buying any more Corsair products after experiencing this kind of customer support.


My setup:
CPU: Intel Core i7-4820K @ 3.70GHz
GPU: NVIDIA GeForce GTX 770, Asus DirectCU II GDDR5 2GB
Motherboard: ASUS Sabertooth X79
PSU: Seasonic Prime Ultra 750 Platinum

Bios: v4801 (25 July 2014)
Chipset: MEI v11.0.5.1189 (28 March 2016)
USB 3.0: ASMedia v10.0.18362.207 (19 June 2019), (Also tried it with USB 2.0 ports but issue persists)

Windows 10 Pro, v1903, Build: 18362.356 (Clean install)

iCue: v3.20.80
Reply With Quote