The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > iCUE Software

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 08-11-2019, 10:06 AM
vulcan78 vulcan78 is offline
Registered User
 
Join Date: May 2017
Posts: 20
POST ID # = 1014356
vulcan78 Reputation: 10
Default K70 MK.2 Low Profile Rapidfire not recognized by iCUE 25%+ of the time.

Yeah, it did it again this morning, when the PC starts it doesn't recognize the keyboard and the profile isn't launched and the iCUE task-bar icon is a red circle with white exclamation mark and if you open iCUE it says that no Corsair keyboard is connected.

This is becoming a problem that is now happening on a weekly or more basis. The last time it happened was 5 days ago.

Restarting the PC doesn't resolve the problem (I just restarted it 3 times in a row and lost my entire previous Chrome session in the process, hence being pretty ****ing pissed and feeling the urge to write this here)

Only completely powering off the PC via PSU for 30 seconds resolves the issue (or physically disconnecting and reconnecting TWO USB cables, if I do this on a weekly basis I'm afraid of damaging the USB ports).

This makes for a 10 minute affair first thing in the morning? Yeah not happy.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 06:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.