The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Legacy Corsair Software

Notices

 
 
Thread Tools Search this Thread Rate Thread Display Modes
  #31  
Old 08-04-2017, 09:51 AM
AlanOC91 AlanOC91 is offline
Registered User
 
Join Date: Apr 2017
Posts: 6
POST ID # = 914583
AlanOC91 Reputation: 10
Default

Sorry for the late reply, I don't visit these forums often.

I see the issue is still occurring and seems to be happening to more people than when I originally had my problem. Out of the blue yesterday I decided to upgrade to the latest version of CUE out of curiosity and my issues have returned with Steam freezing again.

I'm here to hopefully provide Corsair James with some useful information.

The Steam Senior Engineer I was in contact with was Sam Lantinga. James, I will PM you his email address.

Sam's original comment was "It looks like Steam is crashing inside the HID DLL". Sam is a fantastic guy to deal with and he sent me multiple controller debug programs to try test the issue.

James, I have dump files from steam which is what Sam investigated and found the potential issue, I can send these to you if they are of any use to you?

Hopefully we can nail this problem folks. It's very frustrating.


  #32  
Old 08-07-2017, 09:50 AM
fumap fumap is offline
Registered User
fumap's PC Specs
 
Join Date: Aug 2017
Posts: 17
POST ID # = 914957
fumap Reputation: 19
Default

I missed completely this thread! Same is happening to me, down here some more info if needed to Corsair.

Quote:
Hello,

thought I'd try to drop a post here before going for Corsair support. All the issues I'm facing have been reported but seems that all those threads are few years old and no one had all the issues at once! I also read the quick fix and sticky threads to no solution yet.

So, first things first: K70 RGB Rapidfire with a Sabre RGB mice. They are correctly plugged into USB3.0 ports at the back of the case (only the keyboard labelled USB for the K70). And I tried all possible USB port combination.
Motherboard chipset is up to date, same as Win10 and CUE software at 2.15.83.

Firmware for the K70 is the latest 2.05 and the firmware for the Sabre RGB is the latest 2.04. I tried to "force" an update via CUE but didn't solve the issue.

Now, to the problem: keyboard and mice are permanently plugged in and it's possible to type and to use the mice as expected; RGB lighting works and can be controlled in intensity. I have three different issues, probably connected:

1) CUE doesn't recognise the devices. It is 95% of the time my K70 but it happens also to my Sabre RGB mice. I set CUE to NOT load at startup as I saved the profiles into the devices. What happens is that when I open CUE one or both the devices are not recognised. The little icon shows a red exclamation point. Plugging them in and out works as a solution.

2) My K70 lock LEDs stop working few minutes after starting the system up. Functionality is there, just the LEDs don't come up. I startup Win10, they work. After some time they just freezes out. Switching the K70 to BIOS and back solves the issue for some time before it requires another cycle.

3) CUE, Steam, HWMonitor, etc... freeze when the devices are not recognised in CUE. When either the K70 or the Sabre are not recognised, connecting a controller/joystick frezees the running programs but NOT the system completely. This happens at the same time as point 1): when a device is not recognised in CUE plugging in any other device will freeze the system (I tried multiple other devices). And the temporary solution is the same as point 1), plug out and back in the culprit solves the issue temporarily.

I understand that plugging out and back in solves the issue, but it's a bit annoying to always have to do it. Any help/suggestion is appreciated, had those issues since March when I got the devices but it seems to have got worse and worse.
Cheers,
Paolo


  #33  
Old 08-08-2017, 06:50 AM
Darkan's Avatar
Darkan Darkan is offline
Registered User
Darkan's PC Specs
 
Join Date: Aug 2017
Posts: 6
POST ID # = 915081
Darkan Reputation: 10
Default

I bought my Corsair k70 a few days ago, and I am having the
exactly same problems reported above by fumap.

UPDATE:
I Fixed the problem uninstaling the Corsair Link and now teh CUE is working perfectly. But now i cant controll my H100i.

Last edited by Darkan; 08-08-2017 at 06:49 PM.


  #34  
Old 08-10-2017, 05:51 PM
fumap fumap is offline
Registered User
fumap's PC Specs
 
Join Date: Aug 2017
Posts: 17
POST ID # = 915433
fumap Reputation: 19
Default

Quote:
Originally Posted by Darkan View Post
I bought my Corsair k70 a few days ago, and I am having the
exactly same problems reported above by fumap.

UPDATE:
I Fixed the problem uninstaling the Corsair Link and now teh CUE is working perfectly. But now i cant controll my H100i.
Hi,

can confirm this! Corsair Link removed and everything is back to normal, CUE works and recognise my devices. No freeze when any other USB is connected and Steam works perfectly now.

I tried it for an entire afternoon without CL4 and the issues just disappeared!

Any of you other guys got both CUE and Link CL4 running at the same time? Just to check if that can be the issue or we are actually facing two different issues here?


  #35  
Old 08-10-2017, 08:07 PM
BahamutxD BahamutxD is offline
Registered User
BahamutxD's PC Specs
 
Join Date: Feb 2015
Posts: 73
POST ID # = 915445
BahamutxD Reputation: 10
Default

Quote:
Originally Posted by fumap View Post
Hi,

can confirm this! Corsair Link removed and everything is back to normal, CUE works and recognise my devices. No freeze when any other USB is connected and Steam works perfectly now.

I tried it for an entire afternoon without CL4 and the issues just disappeared!

Any of you other guys got both CUE and Link CL4 running at the same time? Just to check if that can be the issue or we are actually facing two different issues here?
I did the same but after some time (less than 24H) the issue started to happen again.

Report back in 24-48


  #36  
Old 08-10-2017, 08:41 PM
Corsair James's Avatar
Corsair James Corsair James is offline
iCUE Product Manager
 
Join Date: Oct 2013
Location: Fremont, CA
Posts: 4,464
POST ID # = 915451
Corsair James Reputation: 75
Default

We finally got in touch with Steam engineers through a gracious user who was able to help with that. While it may take a while to diagnose the issue, we'll work as closely as we can with them to see where the problem lies.

Thank you everyone for your patience and understanding.
__________________

iCUE - A CORSAIR Interface
https://www.corsair.com/us/en/icue


1 members found this post helpful.
  #37  
Old 08-11-2017, 08:17 AM
fumap fumap is offline
Registered User
fumap's PC Specs
 
Join Date: Aug 2017
Posts: 17
POST ID # = 915706
fumap Reputation: 19
Default

Quote:
Originally Posted by Corsair James View Post
We finally got in touch with Steam engineers through a gracious user who was able to help with that. While it may take a while to diagnose the issue, we'll work as closely as we can with them to see where the problem lies.

Thank you everyone for your patience and understanding.
Thanks for the update James! This is good news!


  #38  
Old 08-11-2017, 10:37 AM
MadBullBunny MadBullBunny is offline
Registered User
 
Join Date: Jul 2017
Posts: 15
POST ID # = 915711
MadBullBunny Reputation: 10
Default

I don't think this is a CUE only issue, I think its on steam's end of things. Nearly every time I open discord its a 50/50 chance if steam will entirely lock up. I pretty much have to restart my computer to get steam to log back in. I have a specific setup of OS installs I do on my PCs. This issue was happening on my gaming laptop and my desktop on numerous fresh OS installs.


  #39  
Old 08-11-2017, 02:35 PM
r3v3nant r3v3nant is offline
Registered User
r3v3nant's PC Specs
 
Join Date: Sep 2014
Location: Newbury Park, CA
Posts: 20
POST ID # = 915748
r3v3nant Reputation: 10
Default

Thanks for the updates on this guys. On my gaming rig I had Steam, Link, and Cue all running and getting that Steam lock up issue. I removed Cue and all was good. I have a LOT of lights and fans being controlled by Link so removing that was a hard no. All seems good with Steam since I removed Cue from the equation. I will hold off on moving my LUX RGB back to the gaming rig until this is sorted out.


  #40  
Old 08-17-2017, 08:02 AM
Trooper74 Trooper74 is offline
Registered User
Trooper74's PC Specs
 
Join Date: Jul 2016
Location: UK
Posts: 2
POST ID # = 916467
Trooper74 Reputation: 10
Default

Hey all, I can confirm that plugging in my Void headset to charge with steam running causes steam to stop responding. I am running Software version 2.15.83.

I was searching for a fix when I came across this post, the weird thing is it only started to do this quite recently (last 6 weeks maybe ??).

Usually I charge my headset over night so I don't have to plug it in whilst the PC is running but sometimes I need to charge it whilst playing and doing so crashes Steam.
Even after closing all of steams processes in task manager and relaunching it Steam still hangs for 30+ seconds with a "not responding message" at which point I go make coffee and when I get back all is normal again.

I should add that this occurs either when I connect the headset or unplug it from it's charging cable.

My sys specs are :
Win 10 home 64
i5 6600k
GTX 1070
32GB DDR3 1600
Corsair Strafe silent KB
Corsair Scimitar mouse
Corsair Void wireless 7.1 headset
(check my profile for full specs)


  #41  
Old 09-06-2017, 04:24 AM
alexjlopez alexjlopez is offline
Registered User
 
Join Date: Apr 2015
Posts: 3
POST ID # = 919116
alexjlopez Reputation: 11
Default

I have the same crash in Steam when I connect a controller or go into big picture mode with the K65 RGB keyboard connected. Only happens with the K65, uI'm using a spare Microsoft keyboard in the meantime, which works fine.

Any update on a fix?


  #42  
Old 09-07-2017, 04:38 PM
BahamutxD BahamutxD is offline
Registered User
BahamutxD's PC Specs
 
Join Date: Feb 2015
Posts: 73
POST ID # = 919293
BahamutxD Reputation: 10
Default

Yesterday I had to reinstall W10 and everything was working fine until I got the creators update (or it seemed to work just fine) Now its back to steam crashing/freezing for 1-2 mins.


  #43  
Old 09-13-2017, 07:28 PM
Stratofied Stratofied is offline
Registered User
Stratofied's PC Specs
 
Join Date: Jul 2017
Posts: 7
POST ID # = 919954
Stratofied Reputation: 10
Default

This not only affects Steam, but also causes Battle.net launcher to take 30-60 seconds to launch. If I remove CUE, it launches in <10 seconds. I have confirmed this with several other users in PCMR discord.


  #44  
Old 09-15-2017, 12:50 PM
Breadway Breadway is offline
Registered User
Breadway's PC Specs
 
Join Date: Sep 2015
Posts: 10
POST ID # = 920181
Breadway Reputation: 10
Default

It's getting ridiculous now here too. Since I updated to CUEv2 I've got this problem and someone who plays Rocket League daily with an XBOX One Controller it's really annoying. I've to put every time my K95 RGB to the BIOS setting with the switch at the backside. I hope this gets fixed soon.


  #45  
Old 09-15-2017, 12:57 PM
Lionalonso Lionalonso is offline
Registered User
 
Join Date: May 2016
Posts: 14
POST ID # = 920182
Lionalonso Reputation: 10
Default

Quote:
Originally Posted by Stratofied View Post
This not only affects Steam, but also causes Battle.net launcher to take 30-60 seconds to launch. If I remove CUE, it launches in <10 seconds. I have confirmed this with several other users in PCMR discord.
Exactly the same problema with my setup, i have cue and corsair link.
This is ridiculous.


 

Tags
crash, cue, keyboard, steam

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:45 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.