The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Legacy Corsair Software

Notices

 
 
Thread Tools Search this Thread Rate Thread Display Modes
  #16  
Old 07-06-2017, 12:32 AM
r3v3nant r3v3nant is offline
Registered User
r3v3nant's PC Specs
 
Join Date: Sep 2014
Location: Newbury Park, CA
Posts: 20
POST ID # = 910482
r3v3nant Reputation: 10
Default

I just installed a K70 LUX today and I had cue 2 (the most recent version) running for my M65 RGB already.. without the K70 LUX all works fine, with the K70 plugged in and I try and connect my xbox 360 controller or any other usb peripheral and steam freezes.. This is not happening at all without the K70 LUX plugged in so I guess I am returning the K70 LUX... It's pretty and all but I can't have this crashing of steam.. that is a deal breaker.

edit: this K70 LUX with browns is SUCH a nice kb though.. I might put it on my other PC until the Cue/Steam/K70 LUX usb struggle is sorted out..

Last edited by r3v3nant; 07-06-2017 at 12:41 PM.


  #17  
Old 07-10-2017, 12:04 PM
lowensodium lowensodium is offline
Registered User
 
Join Date: Jul 2017
Posts: 1
POST ID # = 910977
lowensodium Reputation: 10
Default

I have also been having this issue for a while and only recently discovered that it related to Steam and CUE.

Here is what I am seeing.

I have a Corsair K70 RGB Rapid Fire, a Steam Controller, and I have a Microsoft 360 wireless receiver with multiple 360 controllers.

Steam has a feature to allow it to manage other controller types the same way it does the Steam controller, for remapping controls and binding to keyboard input. I first had the issue when this feature was added to steam.

I have the issue with that feature enabled or disabled.

The issue is that when ever I turn on one of my wireless 360 controllers, steam will lock up for several seconds, some times close to 30 seconds. If the Steam controller was turned on and I turn on a 360 controller, steam will freeze, and the steam controller will stop working completely. If I was using a 360 controller(s) first and turn on the steam controller, steam will freeze and the 360 controller(s) will stop working. Controllers will not start working even if I unplug them and plug them back in. But everything seems to work properly if I unplug my keyboard or switch it to bios mode and back again.

Some times the issue happens when only using 360 wireless controllers when a second or 3rd one are turned on (with out the Steam Controller turned on at all).

I have the issue with Steam in the release version and the beta version.

I have the issue with CUE version 1.16 and 2.15

I think the issue happens less often if I set CUE to advance mode, but I can't confirm it.

It also seems that the problem might go away completely if I move my keyboard from on of my Intel USB ports to the ASMedia port. The other devices are still connected to the Intel USB ports.

I have also found another really strange issue that is somehow tied to all of this. The Blizzard app (formally Battle.net) takes a VERY long time to start. Like 30 to 120 seconds. But after I have moved the Corsair keyboard to the ASMedia port, it starts in 2-5 seconds.


  #18  
Old 07-12-2017, 08:27 AM
Stratofied Stratofied is offline
Registered User
Stratofied's PC Specs
 
Join Date: Jul 2017
Posts: 7
POST ID # = 911293
Stratofied Reputation: 10
Default

I have been having this issue for a while now, as does one of my friends. Every single time i plug in or unplug certain usb devices, mainly my xbox one controller. It is definitely linked to CUE, as uninstalling it fixes the issue but leaves me without much needed features of my devices.

And now that you mention it, I also have a really long startup time on my Blizzard launcher and was wondering why. I can no longer recommend any device that uses CUE until these serious issues are fixed.


  #19  
Old 07-13-2017, 06:35 PM
Zotty's Avatar
Zotty Zotty is offline
CORSAIR Beta Team
Zotty's PC Specs
 
Join Date: Apr 2017
Location: South Staffordshire, England, UK
Posts: 3,248
POST ID # = 911578
Zotty Reputation: 52
Default

I had this very issue.. it turned out to be my Strafe RGb and Polaris RGB Mouse mat being plugged into the Gaming Device ports 'Red' usb ports on the rear of my MSI Gaming Motherboard!

Since swapping them into the other usb ports on rear of my mobo the following issues have gone

Steam locking up
Strafe regularly disconnecting from CUE
Polaris Not lighting up at all since latest CUE update
Link Locking up randomly
usb disconnect sound on start up

Last edited by Zotty; 07-13-2017 at 07:19 PM.


  #20  
Old 07-15-2017, 07:27 AM
Stratofied Stratofied is offline
Registered User
Stratofied's PC Specs
 
Join Date: Jul 2017
Posts: 7
POST ID # = 911753
Stratofied Reputation: 10
Default

Tried switching around what ports im plugged into, didnt help at all.


  #21  
Old 07-16-2017, 08:28 AM
Mr_ALLroy's Avatar
Mr_ALLroy Mr_ALLroy is offline
Registered User
Mr_ALLroy's PC Specs
 
Join Date: Feb 2013
Posts: 26
POST ID # = 911886
Mr_ALLroy Reputation: 10
Default

I have a "non RGB" K70 LUX and I'm getting the same issues. Steam locks up until I switch the polling toggle to bios and back. If I leave steam locked up, I get the usb disconnect sound repeating every 10-30 seconds. With or without the CUE software installed. I've even uninstalled my antivirus software. What happens for me is... The CAPS lock, Num lock and scroll lock indicator lights, will cease to function. Although, the functions of CAPS, Num and scroll lock will still work. Switching the polling switch to bios and back to the 1ms position will fix it. And it will sporadically cause the issues again all on its own. I have a razer death adder and have uninstalled the synapse software, with no change. I've swapped usb ports in every combination with my mouse, no luck. I also notice that, the Num lock light will come on during post, but when windows loads, before I log in, that the Num Lock key isn't lit up. But when I log in, it does light up.

This just happened today out of the blue. I can't think of any software I've installed lately that would have caused this. This isn't an isolated issue obviously and other than a hardware defect with the keyboard itself, I can't see any correlation with it being related to software. I'm going to dump a month old image of windows onto my driven see if the problem still exists. I'll post my results after I've tested it.

Last edited by Mr_ALLroy; 07-16-2017 at 08:37 AM.


  #22  
Old 07-17-2017, 10:38 AM
Inheritance's Avatar
Inheritance Inheritance is offline
CORSAIR Beta Team
 
Join Date: Jul 2013
Location: Somewhere in Texas
Posts: 5,305
POST ID # = 912051
Inheritance Reputation: 70
Default

Quote:
Originally Posted by Mr_ALLroy View Post
This just happened today out of the blue. I can't think of any software I've installed lately that would have caused this. This isn't an isolated issue obviously and other than a hardware defect with the keyboard itself, I can't see any correlation with it being related to software. I'm going to dump a month old image of windows onto my driven see if the problem still exists. I'll post my results after I've tested it.
It's not a hardware issue I can promise you that.
__________________
Colors of the RAINBOW shine so bright!
USER IS NOT A CORSAIR EMPLOYEE
Come Join My Discord =(^.^)= [iCUE Guide]
Corsair USER Forums is NOT Corsair Tech Support

Last edited by Inheritance; 07-17-2017 at 10:42 AM.


  #23  
Old 07-17-2017, 05:52 PM
Mr_ALLroy's Avatar
Mr_ALLroy Mr_ALLroy is offline
Registered User
Mr_ALLroy's PC Specs
 
Join Date: Feb 2013
Posts: 26
POST ID # = 912166
Mr_ALLroy Reputation: 10
Default

Quote:
Originally Posted by Inheritance View Post
It's not a hardware issue I can promise you that.
I've re-imaged my pc and pretty much updated everything back to how it was when I started having my issues. So far, fingers crossed, my k70 is working as it should. So yes, you are correct when you say it is NOT a hardware issue. Which I'm quite grateful that it is not.


  #24  
Old 07-18-2017, 06:09 AM
Mr_ALLroy's Avatar
Mr_ALLroy Mr_ALLroy is offline
Registered User
Mr_ALLroy's PC Specs
 
Join Date: Feb 2013
Posts: 26
POST ID # = 912216
Mr_ALLroy Reputation: 10
Default

So, I had the issue occur to me again. This time, the only thing I did, was upgrade Corsair LINK from version 4.7.0.77 to the latest, v4.8.0.82. I've uninstalled LINK and reinstalled version 4.7.0.77. I don't have this issue anymore. I suspect they have updated the USB driver and that may be what's caused the issue for me. I should also mention that I do not have the CUE software installed. I don't have an RGB, just a red led k70 so I see no need to install it.

Last edited by Mr_ALLroy; 07-18-2017 at 06:20 AM.


  #25  
Old 07-19-2017, 08:27 AM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 19,338
POST ID # = 912384
Toasted Toasted Reputation: 124
Default

Which Corsair LINK peripheral device do you have connected to your computer?


  #26  
Old 07-21-2017, 03:47 PM
Storm-Raider Storm-Raider is offline
Registered User
 
Join Date: Mar 2017
Posts: 1
POST ID # = 912799
Storm-Raider Reputation: 10
Default

I have exactly the same issue with my xbox one controllers and my RGB k70.

I did some research and found that is a vastly spread problem, but just a few reach out the connection with the CUE.

I tried newest as oldest version around of cue, as a clean installation of my system, cause i tough it may be caused by some ghosting effect in the usb hub, but neither way it work properly.

The only way is keep the system clean of CUE.

Its a shame to see how the people of the steam tell to customers to put in contact with corsair, and corsair people tell us customers to put in contact with steam.

We are trapped between.


  #27  
Old 07-22-2017, 07:13 AM
Thunder350's Avatar
Thunder350 Thunder350 is offline
Registered User
Thunder350's PC Specs
 
Join Date: Jan 2011
Location: Maryland
Posts: 17
POST ID # = 912863
Thunder350 Reputation: 10
Default

Quote:
Originally Posted by Storm-Raider View Post
Its a shame to see how the people of the steam tell to customers to put in contact with corsair, and corsair people tell us customers to put in contact with steam.

We are trapped between.

I contacted Steams support a few days ago detailing our problems and linking them to the responses we got from Corsair James. After receiving a copy/paste response telling me they don't comment on future fixes and to instead go and "search their forums" or even the steam reddit to see if others have the problem and fixed it there, and after I pushed for a better and more personal response from Steam, this is the response I got.

SteamCorsair.PNG


We can only hope Steam soon reaches out to Corsair to fix this problem!


  #28  
Old 07-22-2017, 11:21 PM
whardy whardy is offline
Registered User
 
Join Date: Jul 2017
Posts: 1
POST ID # = 912944
whardy Reputation: 10
Default

Thought I would chime in here. Just spent a fortune on RGB products from Corsair. Strips, fans, mouse, keyboard, mousepad, cooler. The works.

Confirm I have the same issue. The Xbox One wireless controller causes immense lag and barely works for me. Found this post, I had both the latest CUE and LINK installed. Removed CUE, all is better. Unfortunate considering now I have no lighting to half of my peripherals.


  #29  
Old 07-25-2017, 07:11 PM
Corsair James's Avatar
Corsair James Corsair James is offline
iCUE Product Manager
 
Join Date: Oct 2013
Location: Fremont, CA
Posts: 4,459
POST ID # = 913364
Corsair James Reputation: 75
Default

Quote:
Originally Posted by Thunder350 View Post
I contacted Steams support a few days ago detailing our problems and linking them to the responses we got from Corsair James. After receiving a copy/paste response telling me they don't comment on future fixes and to instead go and "search their forums" or even the steam reddit to see if others have the problem and fixed it there, and after I pushed for a better and more personal response from Steam, this is the response I got.

Attachment 30350


We can only hope Steam soon reaches out to Corsair to fix this problem!
They're welcome to reach out to me anytime as we can't reproduce this issue anywhere with systems we have access to (employee systems or in-house systems). We've hosted many tournaments that use controllers as well with Street Fighter, for example, and don't have this problem. Until we can produce it, or someone gives us remote access to their system and sit with a dev, we can't find out a root cause.

I just want to let everyone know I *do* want to fix it, I just don't know *how* because we can't reproduce it. I only hear what may be a cause but without additional information, its pure conjecture.
__________________

iCUE - A CORSAIR Interface
https://www.corsair.com/us/en/icue


  #30  
Old 07-26-2017, 05:04 PM
BahamutxD BahamutxD is offline
Registered User
BahamutxD's PC Specs
 
Join Date: Feb 2015
Posts: 72
POST ID # = 913479
BahamutxD Reputation: 10
Default

I'm on the same boat. Actually reverted to CUE 2.9.53 as I still had the installer and the issue dissapeared. With latest CUE STEAM would freeze 100% of the times I plugin a Corsair device and usually (maybe always) with a wireless device (gamepads). Actually usb drives or other wired usb peripherals didn't seem to trigger the problem.

edit: uninstalling/installing CUE seems to (atleast temporary) fix the problem. Im again on latest CUE and the problem is gone so far. Will report back if it happens again.

edit: After 24 hours it started happening again although the freeze won't last for long now (15-20secs)

Last edited by BahamutxD; 07-27-2017 at 06:16 PM.


 

Tags
crash, cue, keyboard, steam

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 03:00 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.