The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 04-08-2019, 11:52 PM
Pzuh Pzuh is offline
Registered User
 
Join Date: Apr 2019
Posts: 1
POST ID # = 1000840
Pzuh Reputation: 10
Default K70 RGB MK.2 Stops working randomly

My K70 keeps not working randomly throughout the day for like 10 minutes, until i replug like 10 times it works again. When it stops working the lights stay on but the keys are not responsive. Also, when I unplug my keyboard when it is working and plug it back in, it just stops working as well for 10 minutes. Any fixes?
Reply With Quote


  #2  
Old 04-09-2019, 12:33 PM
Corsair Nick's Avatar
Corsair Nick Corsair Nick is offline
Corsair Employee
 
Join Date: Feb 2016
Posts: 946
POST ID # = 1000889
Corsair Nick Reputation: 39
Default

Couple of things you can try to improve connectivity:

* Connect to a different USB stack directly on the back of the motherboard
* Update your USB drivers to the latest from the motherboard manufacturer's website
* Make sure you're on the latest version of iCUE

You can also check to see if you have the same issue connected to a different PC/Laptop
Reply With Quote


  #3  
Old 04-16-2019, 06:30 PM
dexterrr dexterrr is offline
Registered User
dexterrr's PC Specs
 
Join Date: Mar 2019
Posts: 6
POST ID # = 1001665
dexterrr Reputation: 10
Default

Quote:
Originally Posted by Corsair Nick View Post
Couple of things you can try to improve connectivity:

* Connect to a different USB stack directly on the back of the motherboard
* Update your USB drivers to the latest from the motherboard manufacturer's website
* Make sure you're on the latest version of iCUE

You can also check to see if you have the same issue connected to a different PC/Laptop
Hello i have the sam problem even after a windowa 10 clean install.
I only have open the followin programs: Firefox, twitch, Blizzard APP, WOW, steam and CSGO.

I have icue installed, my bios have all updates installed and all drivers are up to date.
Reply With Quote


  #4  
Old 04-19-2019, 05:12 PM
Corsair Calico Jack's Avatar
Corsair Calico Jack Corsair Calico Jack is offline
Corsair Employee
 
Join Date: Oct 2016
Posts: 583
POST ID # = 1001957
Corsair Calico Jack Reputation: 10
Default

@dexterrr

Do you have the same problem when connected to a different computer?
Reply With Quote


  #5  
Old 04-20-2019, 10:07 AM
dexterrr dexterrr is offline
Registered User
dexterrr's PC Specs
 
Join Date: Mar 2019
Posts: 6
POST ID # = 1001997
dexterrr Reputation: 10
Default

Quote:
Originally Posted by Corsair Calico Jack View Post
@dexterrr

Do you have the same problem when connected to a different computer?
yap, the freezing can occur like in 1 minute or 4/5 days, and i noticed that if leave the computor on like 6h/8h(with play time) the freezing occurs more often.
Now im testing in bios mode and only frozed 1 time in 5 days.

Last edited by dexterrr; 04-20-2019 at 10:13 AM.
Reply With Quote


  #6  
Old 04-22-2019, 02:56 PM
Corsair Calico Jack's Avatar
Corsair Calico Jack Corsair Calico Jack is offline
Corsair Employee
 
Join Date: Oct 2016
Posts: 583
POST ID # = 1002212
Corsair Calico Jack Reputation: 10
Default

Try updating your BIOS to ensure you have the latest for your USB ports: https://us.msi.com/Motherboard/suppo...MING#down-bios

If none of this works, I'd suggest making a ticket for the issue at support.corsair.com
Reply With Quote


  #7  
Old 04-22-2019, 03:28 PM
dexterrr dexterrr is offline
Registered User
dexterrr's PC Specs
 
Join Date: Mar 2019
Posts: 6
POST ID # = 1002215
dexterrr Reputation: 10
Default

Quote:
Originally Posted by Corsair Calico Jack View Post
Try updating your BIOS to ensure you have the latest for your USB ports: https://us.msi.com/Motherboard/suppo...MING#down-bios

If none of this works, I'd suggest making a ticket for the issue at support.corsair.com
its the last one, i dowloaded from that page.
Dunno if thish occurence its only on windows 10 or this old processor.
Reply With Quote


  #8  
Old 08-04-2019, 08:47 PM
c0rderr0y c0rderr0y is offline
Registered User
c0rderr0y's PC Specs
 
Join Date: Aug 2019
Posts: 1
POST ID # = 1013733
c0rderr0y Reputation: 10
Default

My K70 MK2 is doing the same and I am pretty close to giving it away for free. I have spent so much time trying to figure out what is wrong. Its def the keyboard.

Different USB
Latest Bios
Latest drivers
Different PC
Hold ESC for 5 seconds
BIOS Mode

All this and the POS doesnt work and I have to use a cheapy wireless Logitech to use my gaming rig to browse the internet and type this post.....
Reply With Quote


  #9  
Old 08-06-2019, 10:51 AM
vulcan78 vulcan78 is offline
Registered User
 
Join Date: May 2017
Posts: 20
POST ID # = 1013887
vulcan78 Reputation: 10
Default

I have a similar issue where my K70 MK.2 Low Profile Rapidfire isn't recognized by the PC (or iCUE) and I need to physically unplug and re-insert the USB cable(s), simply restarting the PC doesn't fix the issue. This happens on avg. once every few weeks. It isn't a big gripe, but it is annoying.
Reply With Quote


  #10  
Old 12-08-2019, 07:57 AM
Stazza85 Stazza85 is offline
Registered User
Stazza85's PC Specs
 
Join Date: Dec 2019
Posts: 1
POST ID # = 1026714
Stazza85 Reputation: 10
Default

im having the same problem with my K70 MK.2 silent keyboard, has anyone come up with a fix for this or are they just defective?
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 08:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.