The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > iCUE Software

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 05-26-2019, 06:53 PM
Dayglorange's Avatar
Dayglorange Dayglorange is offline
Registered User
Dayglorange's PC Specs
 
Join Date: Mar 2018
Posts: 27
POST ID # = 1005828
Dayglorange Reputation: 10
Default iCue still using masive amounts of CPU for no reason

I encountered this problem before, and a subsequent update seemed to have fixed it - until I updated to the latest version (3.16.56) yesterday. Now it seems to be worse. iCUE CPU usage was anywhere from 40-50% at idle, with the program not even open in the foreground. Only killing the iCUE.exe itself and re-starting it made it go back to normal (still using sometimes over 10%), then Corsair.service started spiking up to 15% or more - but I'm also noticing that when I try to kill any Corsair processes they just come right back instead of staying closed. Which makes it impossible for me to shut down iCUE and everything completely so it still uses a noticeable amount of my CPU especially when gaming. I honestly don't know why this is still happening, even unplugging my headset stand doesn't seem to make a difference anymore. I absolutely LOVE Corsair, but the software is sub-par sometimes compared to other control software I've used for peripherals and it just makes me sad and frustrated because it should just work.
Attached Images
File Type: png icue_cpu.png (203.7 KB, 20 views)
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:33 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.