The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Cases

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 6 votes, 5.00 average. Display Modes
  #1  
Old 07-07-2014, 04:41 PM
Faun Faun is offline
Registered User
Faun's PC Specs
 
Join Date: Jul 2014
Posts: 9
POST ID # = 718153
Faun Reputation: 10
Default Corsair C70 Front Fan/Filter Problem

Hi everyone,

I have a Corsair C70 case and i recently bought Corsair H100i, 2x SP120 PWM High Performance Edition, 2x SP120 High Performance Edition and 2x AF120 Performance Edition fans for my gig.

I installed 2x SP120 to behind the front panel but after one day it started to make a scratching sound. I inspected the filter and front panel because there was no problem at the mounting of fans, and i figured out the problem was the mesh of filter lost its tightness and become more close to fans and was rubbing to fans, so i changed the front filter with one of the bottom filters. For couple of days the scratching sound was gone but now it started again and it drives me crazy. I don't know if the problem is filter's loosening meshes or the short front panel but, i have to solve this problem or i'll go insane. I am living at Turkey and all these Corsair parts really really expensive at here, after a lot of spending this is really frustrating for me. So please help me.

Thanks for the replies.
Reply With Quote


  #2  
Old 07-08-2014, 02:41 AM
TBrandes's Avatar
TBrandes TBrandes is offline
Registered User
TBrandes's PC Specs
 
Join Date: Jun 2012
Location: Germany
Posts: 154
POST ID # = 718196
TBrandes Reputation: 10
Default

Not having the case and without some better pics it's a bit difficult to help. But i'm giving it a shot anyway... ;)

1. Install the fans which came with the front and turn the filter around (with the bulge of the mesh outward). Assuming that pic #5 shows the correct filters. With less airflow this should resolve the problem.
2. Given enough room you might try a gasket like it is used for watercooling. This gives you more room between the fans and the filter and would solve the problem.
3. If there's only little room to solve this you might try to install a radiator grill which would hinder the filter getting contact with the fan.

Instead of the radiator grill you can also use aluminium fan filter. Those are less expensive and might be easier to get.

Btw. the links are only for showing some pics. ;)

Last edited by TBrandes; 07-08-2014 at 03:42 AM.
Reply With Quote


  #3  
Old 07-08-2014, 02:09 PM
Faun Faun is offline
Registered User
Faun's PC Specs
 
Join Date: Jul 2014
Posts: 9
POST ID # = 718265
Faun Reputation: 10
Default

I ll not use the stock fans because of their performance and besides they weren't at front panel from start, they were at behind hdd cages and i changed them with af120s. I just installed 2 additional sp120s to front panel, and there shouldn't be any problem because the fans and case, both of them corsair's. There shouldn't be any incompatiblity. The thing i wonder, is this is a malfunction of the case or fans? I installed everything correctly. My h100i is works fine with its sp120s, my af120s working fine behind the hdd cages. Just this front panel and filter causing the problem.

Btw all three filters are the same and Sp120's already have gaskets if you mean their colorful rings.
Reply With Quote


  #4  
Old 07-08-2014, 05:04 PM
thenosbod's Avatar
thenosbod thenosbod is offline
Homo sapien
thenosbod's PC Specs
 
Join Date: May 2013
Location: Earth UK
Posts: 565
POST ID # = 718302
thenosbod Reputation: 60
Default

http://forum.corsair.com/forums/showthread.php?t=130372
__________________
I do not work for Corsair and I am not an official forum helper.
Reply With Quote


  #5  
Old 07-24-2014, 06:48 AM
Faun Faun is offline
Registered User
Faun's PC Specs
 
Join Date: Jul 2014
Posts: 9
POST ID # = 720387
Faun Reputation: 10
Default

Any official forum helper? I tried to explain my problem but not a response from a official helper. I have this exact problem which i linked below, i think he explained better than me because he got help. i can provide photos or a video.

http://forum.corsair.com/v3/showthread.php?t=121210
Reply With Quote


  #6  
Old 07-25-2014, 06:21 AM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 19,342
POST ID # = 720549
Toasted Toasted Reputation: 124
Default

Put in a ticket and explain your issue. Corsair should be able to help you.
Reply With Quote


Reply

Tags
c70, fans, filter, front panel, sp120

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:12 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.