The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Cooling

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 06-21-2019, 04:03 PM
Exidrial Exidrial is offline
Registered User
Exidrial's PC Specs
 
Join Date: Feb 2016
Posts: 22
POST ID # = 1008821
Exidrial Reputation: 10
Default I'm only having trouble with RGB

I know that the post title is provocatice but hear me out. I am somewhat angry right now, imo rightly so because I spent a lot of money on corsair products. I am not creating this post to bash Corsair, I'm just hoping somebody reads this and can give me some explanation as to why the things are as they are or why certain problems still aren't fixed. I am typing this as I finished the post so please keep in mind that at the time of typing the largest part of the post I was angry.

I bought into the whole Corsair ecosystem. I own an h115i Platinung, an AX860i, 5 LL fans, 4x8GB sticks of Vengeance RGB Pro, commander pro, M65 pro, Strafe RGB, (and an RGB strip on my custom V1Tech backplate).

Really I, for the most part, love your products. And yes they perform their base funtctions. My keyboard types, my fans blow air and so on. But the RGB implementation sometimes feels very sloppy.

I am completely honest with you, I am probably getting more angry than I am supposed to over computer parts but I spent probably close to 1000€ just for this setup on corsair parts. I am expecting them to delvier an experience that's worth that much money.

Let me explain what my issues are. Some of those might just be bad luck, stuff breaks and it's not a big deal. But pretty much all my issues are related to RGB.

On my Strafe RGB for example, the LEDs on the spacebar broke, it only lights up red anymore.

The h115i Pro still has that problem where it disconnects and then sometimes reconnects but then the LEDs spazz around until you restart iCue. I already downloaded the most recent firmware but this issue keeps happening. Talking of firmware, I can't even update my Strafe RGB and m65 pro anymore, it keeps failing.

The RAM sticks, this is not a technical issue but more a feature issue. You can't overlay effects. Why? I mean you CAN overlay effects if you turn on software control for the sticks but that pushes iCues CPU usage to 15%-20% at all times on an i7-8700K.

Now my LL120s are starting to have some problems too. One of my LL120s right side completely only lit up Green. I restarted my pc and then suddenly the right side wouldn't light up at all. I tried playing around in iCue, didn't fix it. This is what caused me to write this post. At the time of writing the issue resolved itself, the LEDs in the fan randomly decided to work properly again. I doubt this was a software issue as the problem persisted even when I closed down iCue but I'm not a Corsair engineer so don't take my word for it.

Really, I didn't make this post to bash Corsair. I just wanted to vent some of my frustration. I love your products, keep bringing RGB glory to the PC. I'm looking forward to buying your RGB mousepad (as soon as you release a large one that covers the mouse and keyboard area, make it happen corsair!) and maybe your Hydro X stuff in the future.

Edit:
The LEDs in my right control key randomly broke, white looks pink now. I didn't even press it /:

Last edited by Exidrial; 06-21-2019 at 05:15 PM.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 05:20 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.