The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Cooling

 
 
Thread Tools Search this Thread Rate Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 05-25-2019, 03:12 PM
Violett Violett is offline
Registered User
Violett's PC Specs
 
Join Date: May 2019
Posts: 27
POST ID # = 1005703
Violett Reputation: 10
Sigh.. Problems with radiator Corsair H115i RGB Platinum

Hello guys ! Right now, I have another problem with the radiator of the AIO cooler - Corsair H115 i RGB Platinum.
After I putted the fans on the radiator, the screws work to screw easily with the fingers, but stop at one moment, far away from the point when the head of the screw touch the radiator, with a considerable distance, like in the pictures.
I do not know what to do, because I am affraid if I continue to screw, somehow the fins of the radiator will be dammaged. I observed closely that the screws going down thru the radiator in such a tube, normally the tube must be opened, not blocked, but my tubes seems to be blocked by something wich I don’t know what is.
I saw all the tutorials on Youtube, and in most clips, the screwing is easy, from the start to the finish point, and in others, the screwing is easy until one point, and then is done with some force to the end.
In the first picture, you can see the point of the screw after is necessary to apply force to screw. I think the screw is correctly introduced in its hole (perpendicular).

Last edited by Violett; 05-25-2019 at 03:24 PM.
Reply With Quote


 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 08:48 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.