The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Cooling

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 11-02-2017, 12:54 AM
ZestyGrandpa ZestyGrandpa is offline
Registered User
ZestyGrandpa's PC Specs
 
Join Date: Nov 2017
Posts: 1
POST ID # = 925169
ZestyGrandpa Reputation: 10
Default HD120 RGB Problems

So I've looked just about everywhere on these forums for a solution to my problem, but it seems I have a fairly unique case on my hands...

I recently purchased a 460x with the intention of switching out the RGB fans it comes with for HD120's. I was going to wait until I had a little more money but from the git go the SP fans in the 460x were malfunctioning from the very start. There would be only one fan lit up and it was very dim, so I decided to just make the plunge and buy the 3 fan HD120 kit.

The first kit I bought was an open box deal so I knew there could be potential trouble. I installed the kit per the directions making sure to swap out the SP Lighting Controller with the HD one provided in the kit and also changing out the Lighting Hub with the new one just in the event that the one the case came with was defective. With everything properly powered I turned on my PC and now only 2 of the fans would light up. I called Corsair's tech support and they had me try each fan individually in the #1 slot on the hub. The two fans that would light up originally were the only ones that would work in that slot but they still were very dim and the controller could not change them either. The tech support agent said I should try exchanging the open box for a brand new kit.

The next day I exchanged the used kit for a brand new one and went home immediately to install them. I cautiously installed them this time as to not potentially damage their delicate ecosystem. I screwed the fans into place first and then connected them each to the motherboard. I then stuck the controller and hub to the respective areas and connected the SATA power to hub as well as the controller to the hub. Next I connected the controller to the front IO of 460x so that I could control the fans from the case instead of the internal controller. I then routed the fan wires to their proper 1, 2, 3 positions in the hub and powered everything on. The fans only partially lit and eventually one of them just stopped working all together. I still had no control over their functionality from either the case controller buttons or the provided controller. I called tech support again and walked them through my process. The tech agent asked that I try each fan individually in the #1 slot and so I did. Each fan lit up, but only partially. The tech agent asked if I had connected the controller to the front IO cables on both installation attempts and so he deduced that the common denominator was trying to use the front panel controller. He said it could be shorting out the hub or controller or the fans themselves and that I should return the kit for a new one and this time not connect the controller to the front IO. He also said to make sure to not disconnect or connect any fans or SATA power cables while the PC was running.

I went to the store and swapped out the kit again. I installed everything the same way except I made sure to not connect the case to the controller this time. I powered the PC on and all three lit up but were slightly different colors and still were not as bright as they should be. Some of the LED's on each fan were lit, but only very very dimly. I turned off the PC each time I tried to change a cable or swap a fan cable with another and still no luck. I tried several different SATA power cables but eventually the whole kit stopped lighting up all together and has not since.

Long story short... I'm on kit #3 and have tried 3 different ways of installing these fans and have yet to get them working correctly for even 10 seconds. I don't think I want to try another kit, so perhaps I'll just give up on my RGB setup.

Any help or input would be greatly appreciated.

Thank you
Reply With Quote


Reply

Tags
hd120, hd120 rgb, rgb lighting, rgb lighting setup, rgb lighting wrong

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:50 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.