The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Cases

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 03-04-2017, 03:17 AM
Meatloafmt Meatloafmt is offline
Registered User
Meatloafmt's PC Specs
 
Join Date: Mar 2017
Posts: 5
POST ID # = 893764
Meatloafmt Reputation: 10
Default New Case with new problems

I recently built a 570x and after installing everything only 2 out of my 6 hd120 fans are lighting up but all 6 are working and functioning otherwise properly. I have narrowed the problem down to either the PSU which I have a EVGA G2 650 or the controller for the fans on the back. The controller is where I think the problem is, as I have tried multiple different configurations of fans plugged into it and only the first two slots are lighting up. I have no clue what I could do to fix this so I came to here, thanks to everyone that is willing to help me out.
Reply With Quote


  #2  
Old 03-04-2017, 06:43 AM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 19,344
POST ID # = 893778
Toasted Toasted Reputation: 108
Default

The fans need to be connected in series. e.g. 1 > 2 > 3 > 4 > 5 > 6.

More information can be found in the fan for the fans which can be found in the downloads tab of the SP/HD RGB fans.
Reply With Quote


  #3  
Old 03-04-2017, 12:19 PM
Meatloafmt Meatloafmt is offline
Registered User
Meatloafmt's PC Specs
 
Join Date: Mar 2017
Posts: 5
POST ID # = 893812
Meatloafmt Reputation: 10
Default

I do have all fans connected to the fan hub and all are powered but it seems as only slots 1 and 2 are working and ports 3-6 are not. Even with the fans lighting up in ports 1 and 2, none of the fan controller buttons are changing these two fans as they are only solid white.
Reply With Quote


  #4  
Old 03-05-2017, 06:12 AM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 19,344
POST ID # = 893924
Toasted Toasted Reputation: 108
Default

Put in a support ticket with Corsair and explain your situation, It seems there could be a possible issue with the controller.

https://corsair.secure.force.com/
Reply With Quote


Reply

Tags
570x, controller, hd120

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 04:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.