The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Corsair Utility Engine (CUE) 1.x and 2.x > CUE 1.x and 2.x SDK

 
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 05-20-2016, 12:32 PM
Chiruno Chiruno is offline
Registered User
 
Join Date: May 2016
Posts: 1
POST ID # = 853546
Chiruno Reputation: 10
Default CorsairGetLedPositions() returning empty?

Hey folks,

I'm currently working with the CUE SDK in C++, and am having a peculiar issue I'm hoping someone in here will be familiar with. I've searched around, but haven't seen anything as of yet.

In the provided example code, there is a function getAvailableKeys that builds a vector of CorsairLedColor objects. In order to build this vector, it calls CorsairGetLedPositions(). My issue, is that CorsairGetLedPositions() is returning an object with numberOfLed = 0 and pLedPosition = NULL. I double checked the device it's detecting and executing for, and it's definitely my K70 RGB.

My progression of interaction with the device using the SDK has been:

CorsairPerformProtocolHandshake()
CorsairRequestControl(CAM_ExclusiveLightingControl)
getAvailableKeys()

...where getAvailableKeys() is quite literally copy-pasted from the example code.

Anyway, I'm going to continue tinkering with this, but if anyone has any ideas I'd be more than glad to hear them.

Thanks.

Edit: I've now gone and compiled the solution provided by Corsair with zero changes. Same behavior, and the example code doesn't work as a result, either.

Edit 2: Using CorsairGetLedIdForName in the "text_highlight" example code yields CLI_INVALID.

Edit 3: I've fixed my own problem. Probably should have tried this before, but unplugging the keyboard, killing the CUE process, plugging it back in, and starting CUE fixed the problem. Weird bug, considering it was working fine with the CUE application itself.

Last edited by Chiruno; 05-20-2016 at 03:17 PM.
  #2  
Old 06-14-2016, 04:56 PM
vhexs's Avatar
vhexs vhexs is offline
Custom User Title
vhexs's PC Specs
 
Join Date: May 2016
Location: England
Posts: 46
POST ID # = 858116
vhexs Reputation: 12
Default

Where did you download the SDK? I can't find it. :/
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 04:53 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.