The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Corsair Utility Engine (CUE) 1.x and 2.x

Closed Thread
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 04-28-2017, 07:52 PM
AlanOC91 AlanOC91 is offline
Registered User
 
Join Date: Apr 2017
Posts: 6
POST ID # = 901163
AlanOC91 Reputation: 10
Default CUE Causing Steam Crash

Hey folks.

To cut a very very long story short.

CUE crashes steam 3 times out of 5 when I turn on/off any form of a controller. I'd go as far as to say it would crash steam whenever a USB device in general is inserted.

I've had this problem since December 2016 and have literally tired everything to fix it. Only tonight was it pointed out to me that it's a USB device causing the issue, after some Googling it seems CUE is causing it.

I initially thought it was a Steam issue and actually ended up in a week long email exchange with a Senior Valve Engineer. After inspecting my latest dump file when my steam crashed he said:

"Thanks for the dump. It’s confirmed that Steam is blocked in a Windows USB device driver call."

He then told me it may be my keyboard as during one of our tests it wouldn't crash while the keyboard was unplugged.

At this stage I think it's CUE. I'm tempted to download an older version to see if that fixes it but is there any other possible solution to this?

I would be so very grateful. This issue has hounded me for months now and is ruining my controller experience on steam.

My keyboard is Corsair K65 RGB. I have the latest version of CUE.


  #2  
Old 04-29-2017, 05:15 AM
AlanOC91 AlanOC91 is offline
Registered User
 
Join Date: Apr 2017
Posts: 6
POST ID # = 901187
AlanOC91 Reputation: 10
Default

I can confirm that completely uninstalling Corsair Utility Engine has resolved the issue...

I'm going to try version 1.6 to see if it works for me.
There seems to be an issue for certain people in the latest build where it acts really funny with USB devices and cripples Steam.


  #3  
Old 04-30-2017, 05:03 AM
floxigen floxigen is offline
Registered User
floxigen's PC Specs
 
Join Date: Apr 2017
Posts: 15
POST ID # = 901290
floxigen Reputation: 10
Default

Same issue and I have it since v1 !


  #4  
Old 04-30-2017, 07:28 AM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 19,344
POST ID # = 901303
Toasted Toasted Reputation: 108
Default

Strange, This was a known issue in the very early stages of the Vengeance RGB keyboards but was resolved via a firmware update if i recall correctly.

You will want to put in a support ticket with Corsair and see whether they can reproduce your issue on their side.
https://corsair.secure.force.com/


  #5  
Old 05-01-2017, 02:29 AM
Inheritance's Avatar
Inheritance Inheritance is offline
CORSAIR Beta Team
 
Join Date: Jul 2013
Location: Somewhere in Texas
Posts: 5,308
POST ID # = 901431
Inheritance Reputation: 70
Default

Quote:
Originally Posted by AlanOC91 View Post
I can confirm that completely uninstalling Corsair Utility Engine has resolved the issue...

I'm going to try version 1.6 to see if it works for me.
There seems to be an issue for certain people in the latest build where it acts really funny with USB devices and cripples Steam.
do you have any other software installed that would be grabbing or messing with the device inputs?
__________________
Colors of the RAINBOW shine so bright!
USER IS NOT A CORSAIR EMPLOYEE
Come Join My Discord =(^.^)= [iCUE Guide]
Corsair USER Forums is NOT Corsair Tech Support


  #6  
Old 05-01-2017, 08:08 AM
AlanOC91 AlanOC91 is offline
Registered User
 
Join Date: Apr 2017
Posts: 6
POST ID # = 901464
AlanOC91 Reputation: 10
Default

Quote:
Originally Posted by Inheritance View Post
do you have any other software installed that would be grabbing or messing with the device inputs?
Nothing that I am aware of. I'm pretty sure it's 100% CUE considering it works perfectly with v1.6 and seems to have numerous USB issues with v2 onwards.

For reference, here is a lit of my startup programs:


  #7  
Old 06-12-2017, 01:49 AM
cxmachi cxmachi is offline
Registered User
 
Join Date: Jun 2017
Posts: 11
POST ID # = 907644
cxmachi Reputation: 10
Default

I'm having this exact same issue. Can you please let me know what you've done to resolve it? Is it simply just using an older version of CUE? If so, what is best? I'm using a K70 Lux RGB. Thanks, really need this.


  #8  
Old 06-12-2017, 05:11 AM
AlanOC91 AlanOC91 is offline
Registered User
 
Join Date: Apr 2017
Posts: 6
POST ID # = 907662
AlanOC91 Reputation: 10
Default

For anyone curious:

Downgrading to V1.6 fixed the issue to me. According to a Steam senior engineer, it's an issue with CUE and USB priority.

Contacting/telling Corsair about it was pointless. Like banging my head against a wall.


  #9  
Old 06-13-2017, 05:23 PM
Corsair James's Avatar
Corsair James Corsair James is offline
iCUE Product Manager
 
Join Date: Oct 2013
Location: Fremont, CA
Posts: 4,456
POST ID # = 907851
Corsair James Reputation: 75
Default

Quote:
Originally Posted by AlanOC91 View Post
For anyone curious:

Downgrading to V1.6 fixed the issue to me. According to a Steam senior engineer, it's an issue with CUE and USB priority.

Contacting/telling Corsair about it was pointless. Like banging my head against a wall.
CUE 1.16 uses a different driver than CUE 2.X. Who was this steam engineer you spoke to? If they can provide to us the data of this USB priority, we can fix it because we can't reproduce it internally (and its not a widespread issue).
__________________

iCUE - A CORSAIR Interface
https://www.corsair.com/us/en/icue


  #10  
Old 06-13-2017, 08:35 PM
cxmachi cxmachi is offline
Registered User
 
Join Date: Jun 2017
Posts: 11
POST ID # = 907885
cxmachi Reputation: 10
Default

Quote:
Originally Posted by Corsair James View Post
CUE 1.16 uses a different driver than CUE 2.X. Who was this steam engineer you spoke to? If they can provide to us the data of this USB priority, we can fix it because we can't reproduce it internally (and its not a widespread issue).
I believe it's more widespread than you think. It may just be that users are not plugging in controllers or mice often enough. If you take a look at this thread I started, another user is having the exact same issue as I am.

http://forum.corsair.com/v3/showthread.php?t=168442

There's also a lot more reports of it with the exact same issue.

http://forum.corsair.com/forums/showthread.php?t=167509
http://forum.corsair.com/forums/showthread.php?t=168442
http://forum.corsair.com/v3/showthread.php?p=899462
http://forum.corsair.com/forums/show...ighlight=steam
https://www.reddit.com/r/Steam/comme...ny_usb_device/

I did quite a bit of testing and the culprit is definitely the driver that CUE is installing. When I completely uninstall CUE, the issue no longer happens to me.

In my steps to reproduce in the thread I started:

Steps to Reproduce:
1. Start computer.
2. Notice that CUE has loaded up since my lights are showing RGB effects
3. Plug in a USB device like a controller or another mouse
4. Notice that Steam freezes and is unusable. ALSO notice that if you press Caps Lock or Numlock, the lights will not light up, no matter what you do.
5. Set polling switch to BIOS
6. Steam now unfreezes and is usable.
7. Set polling back to default. Caps lock and Numlock also now works again.
8. You can now unplug and replug USB devices without issue, but this only lasts for maybe 1 or 2 replugs. You have to go back to Step 1 again.

If I have CUE installed, I only need to unplug and replug USB devices about 3 times before I experience the issue.

When I completely uninstalled CUE, I tried unplugging and replugging USB devices using the same steps and even after 30 tries, I no longer get the issue. Definitely a driver issue due to the Corsair Composite Virtual Input Device.

Also, even downgrading to 1.16, I get the same issue but less frequent. (happened at about 8 cycles of unplugging and re-plugging a USB device)

It's really, really easy to reproduce so I really hope you guys are able to do it on your end. It sucks to have an RGB keyboard where you can't use the software in the first place to change the RGB lights.


  #11  
Old 06-15-2017, 05:04 PM
CCFAN's Avatar
CCFAN CCFAN is offline
Registered User
CCFAN's PC Specs
 
Join Date: May 2017
Posts: 20
POST ID # = 908163
CCFAN Reputation: 10
Default

I heard about it before, but it doesn't occur in my laptop.

I think they fixed the problem already. I'm using Version 2.14.67, and device is M65 Pro RGB. Steam works normally.


  #12  
Old 06-15-2017, 05:10 PM
CCFAN's Avatar
CCFAN CCFAN is offline
Registered User
CCFAN's PC Specs
 
Join Date: May 2017
Posts: 20
POST ID # = 908166
CCFAN Reputation: 10
Default

Quote:
Originally Posted by cxmachi View Post
I believe it's more widespread than you think. It may just be that users are not plugging in controllers or mice often enough. If you take a look at this thread I started, another user is having the exact same issue as I am.

http://forum.corsair.com/v3/showthread.php?t=168442

There's also a lot more reports of it with the exact same issue.

http://forum.corsair.com/forums/showthread.php?t=167509
http://forum.corsair.com/forums/showthread.php?t=168442
http://forum.corsair.com/v3/showthread.php?p=899462
http://forum.corsair.com/forums/show...ighlight=steam
https://www.reddit.com/r/Steam/comme...ny_usb_device/

I did quite a bit of testing and the culprit is definitely the driver that CUE is installing. When I completely uninstall CUE, the issue no longer happens to me.

In my steps to reproduce in the thread I started:

Steps to Reproduce:
1. Start computer.
2. Notice that CUE has loaded up since my lights are showing RGB effects
3. Plug in a USB device like a controller or another mouse
4. Notice that Steam freezes and is unusable. ALSO notice that if you press Caps Lock or Numlock, the lights will not light up, no matter what you do.
5. Set polling switch to BIOS
6. Steam now unfreezes and is usable.
7. Set polling back to default. Caps lock and Numlock also now works again.
8. You can now unplug and replug USB devices without issue, but this only lasts for maybe 1 or 2 replugs. You have to go back to Step 1 again.

If I have CUE installed, I only need to unplug and replug USB devices about 3 times before I experience the issue.

When I completely uninstalled CUE, I tried unplugging and replugging USB devices using the same steps and even after 30 tries, I no longer get the issue. Definitely a driver issue due to the Corsair Composite Virtual Input Device.

Also, even downgrading to 1.16, I get the same issue but less frequent. (happened at about 8 cycles of unplugging and re-plugging a USB device)

It's really, really easy to reproduce so I really hope you guys are able to do it on your end. It sucks to have an RGB keyboard where you can't use the software in the first place to change the RGB lights.
I have my wireless controller receiver connected at start up, and seeing no issue.


  #13  
Old 06-15-2017, 06:46 PM
Corsair James's Avatar
Corsair James Corsair James is offline
iCUE Product Manager
 
Join Date: Oct 2013
Location: Fremont, CA
Posts: 4,456
POST ID # = 908180
Corsair James Reputation: 75
Default

@CCFan, its very sporadic and your results are the same as what we see internally.

@cxmachi, we've followed your steps as well as other steps posted elsewhere. No dice. The only thing I can find in common is that it has to deal with a Steam update around the same time period. If you noticed, no one had this issue prior last year and we didn't do anything in CUE that changes how USB is enumerated.
__________________

iCUE - A CORSAIR Interface
https://www.corsair.com/us/en/icue


  #14  
Old 06-19-2017, 05:03 AM
Thunder350's Avatar
Thunder350 Thunder350 is offline
Registered User
Thunder350's PC Specs
 
Join Date: Jan 2011
Location: Maryland
Posts: 18
POST ID # = 908659
Thunder350 Reputation: 10
Default

I've been having this issue for months myself, however it happens nearly everytime I plug in or unplug my Corsair Void headset to charge it (my former h2100's also had the same issue). Corsair's support back then was unable to find a solution. Would be nice if Corsair could look into this more and reach out to Steam and those having the issue to get this resolved.


  #15  
Old 06-20-2017, 05:20 PM
Corsair James's Avatar
Corsair James Corsair James is offline
iCUE Product Manager
 
Join Date: Oct 2013
Location: Fremont, CA
Posts: 4,456
POST ID # = 908859
Corsair James Reputation: 75
Default

Quote:
Originally Posted by Thunder350 View Post
I've been having this issue for months myself, however it happens nearly everytime I plug in or unplug my Corsair Void headset to charge it (my former h2100's also had the same issue). Corsair's support back then was unable to find a solution. Would be nice if Corsair could look into this more and reach out to Steam and those having the issue to get this resolved.
It'd be nice if Steam could reach out to us too since this is entirely on their end from my POV. Im sure they get just as many complaints from their users as we do regarding this issue.
__________________

iCUE - A CORSAIR Interface
https://www.corsair.com/us/en/icue


Closed Thread

Tags
crash, cue, keyboard, steam

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:15 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.