The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Corsair Link

Closed Thread
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 02-10-2017, 04:30 AM
Technobeard's Avatar
Technobeard Technobeard is offline
Bearded Corsair Employee
 
Join Date: Oct 2012
Posts: 4,286
POST ID # = 890769
Technobeard Reputation: 68
Default Discuss Link v4.5.0.55 here

This will be the official discussion thread for Link v4.5.0.55.

If you'd like to report a bug, please respond to this thread in this format:
  1. Version of your Link software. NOTE: If you're not using v4.5.0.55, please install it and see if the bug has been fixed.
  2. What version of Windows you're using.
  3. Summary - One line / sentence explaining the issue
  4. Detailed description of the issue - This part can be as long as you want. It should be detailed enough so that we can clearly identify the issue and attempt to replicate it.
  5. Attach photos of the issue to the post that help #4.

Quote:
02/10/2017 - Corsair Link Software Update Version 4.5.0.55

Changelog:
  • Added support for Lighting Node PRO
  • Added new product support for the CORSAIR Lighting Node PRO
  • Added Mimic color animation - display animation for selected lighting effect in the user interface
  • Fixed Vengeance LED modules when only one unit was controlled (Z170/Z270 motherboards only)
  • Condensed DRAM layout to display modules with the same SPD in one section.
  • Performance and stability improvements, minor bug fixes

Last edited by Technobeard; 02-23-2017 at 01:05 AM.


1 members found this post helpful.
  #2  
Old 02-10-2017, 10:38 AM
gilad215 gilad215 is offline
Registered User
 
Join Date: Feb 2017
Posts: 4
POST ID # = 890709
gilad215 Reputation: 10
Default Corsair Link v4.5.0.55

[*]Performance and stability improvements, minor bug fixes ?????
Are we worthy?

http://www.corsair.com/en/support/downloads

Last edited by Technobeard; 02-10-2017 at 08:50 PM. Reason: merged with main thread - de-duped data


  #3  
Old 02-10-2017, 11:04 AM
red-ray red-ray is offline
Banned
red-ray's PC Specs
 
Join Date: May 2014
Location: England (GMT+1)
Posts: 7,152
POST ID # = 890711
red-ray Reputation: 81
Angry Failing to support Kaby Lake is outrageous

Quote:
Originally Posted by Technobeard View Post
  • Fixed Vengeance LED modules when only one unit was controlled (Z170/Z270 motherboards only)
  1. Failing to support Kaby Lake is outrageous . Looking at my earlier post all it takes to fix this is a later CPUIDSDK.dll so one should be attached to the first post in this thread.
  2. It's also totally failing to report the 2 x Corsair Vengeance LED modules, is this the intended fix?
  3. One HDD + my NVMe SSD are still not reported. They are JBOD and not members of a CSMI RAID array. Fixed in 1.1.5.5 cpuidsdk.dll.
  4. Most of this all down to the CPUIDSDK being ancient. It's the same as came with CL 4.3.0.154 and even I am lost for works as to how incompetent this is.
  5. NZXT ship a far later CPUIDSDK that supports Kaby Lake and so should Corsair .
  6. CL4 should display it's version number as I find many members fail to specify this or state "latest version" when posting.
  7. Eight temperatures should be reported rather than three. Fixed in 1.1.5.5 cpuidsdk.dll. I further feel CL4 should use meaningful names rather than the Temp #1 form it currently uses, same for the fan names.
  8. VBAT is not ~2.0 volts and this needs to be fixed. Fixed in 1.1.5.5 cpuidsdk.dll.
  9. I suspected many of these issues would be trivial for a competent software engineer to fix and that I should prove this, see http://forum.corsair.com/forums/showthread.php?p=891269.
  10. Reporting the same disk temperature twice is silly and causes confusion for some, see the 2nd #2 in http://forum.corsair.com/forums/showthread.php?p=890673
  11. From the SIV screen shot you should see all correctly reported.
  12. SIV can also control both DIMM LEDs based on a temperature, when will CL4 be able to do this?
  13. SIV can control the H110i + H110iGT pump speed using a Custom Curve, when will CL4 be able to do this?
The CPUID SDK that comes with CL CL 4.5.0.55 is ancient and as a result my DIMMs and NVMe Disks still don't get reported. Why was such an old CPUID SDK released?

The interlocking semantics are still incorrect and given I reported this on 09-Aug-2016 why? I also e-mailed the product manager who did not even reply to my e-mail. I suspect it's a one line change and can be tested using SIV 5.12 or later. It might have been half fixed, but when I open Configure Fan then pressed [Apply] a few times [Link Test] reported @ 00:29:50.894 seq 40 5 = CreateFile( \\?\usb#vid_1b1c&pid_0c02#7289_1.0#{3c5e1462-5695-4e18-876b-f3f3d08aaf18} ) Access is denied. so I expect the CL4 locking semantics are still incorrect in some of the CL4 code. See http://forum.corsair.com/forums/showthread.php?p=892949 for the details.

No fix for http://forum.corsair.com/forums/showthread.php?p=854759 is pathetic and as I specified before to fix -ve X and fail to fix -ve Y is incompetent!

How do I download new firmware into my CL Minis + H100i + H110iGT?

Have any of the following firmware bugs been addressed some of which have now been outstanding since 20-Nov-2014? If not on what date are they scheduled to be addressed please?
  1. http://forum.corsair.com/forums/showthread.php?t=134621 - Commander Mini will not control fans based on temp sensors
  2. http://forum.corsair.com/forums/showthread.php?p=757703 - Commander Mini + H100i + H80i fan mode register is not returned correctly.
  3. http://forum.corsair.com/forums/showthread.php?t=137364 - Commander Mini + RGB LEDs - Blinking Issue.
  4. http://forum.corsair.com/forums/showthread.php?p=754023 - 10,000 RPM Fans #1 - Corsair suspect it's a firmware bug of 16-Jan-2015.
  5. http://forum.corsair.com/forums/showthread.php?p=709734 - H100i + H80i incorrect colour if you use zero, use 255,1,1 rather than 255,0,0.
  6. http://forum.corsair.com/forums/showthread.php?p=855427 - H100i + H80i you can't use 1,1,1 rather than 0,0,0 as this is not black.
  7. http://forum.corsair.com/forums/showthread.php?p=837226 - CLCC support for 0% PWM or 0 RPM to stop the fans.
  8. http://forum.corsair.com/forums/showthread.php?p=893630 - H110i + H110iGT Custom mode does not work for the pump.
Some fixes appear to get promised, but then never seem to be released.
Quote:
Originally Posted by Corsair Dustin View Post
This is a known issue with a fix coming.
This was posted over 24 months ago on 02-Feb-2015 so I would have expected it to be fixed by now. On what date is the fix expected? On 03-Feb-2015 Corsair stated:

Quote:
Originally Posted by Corsair Dustin View Post
I believe it requires a firmware update to be corrected. It should be in the next Corsair Link drop, or the one after.
There have been at least 9 CL drops since then .

Quote:
Originally Posted by Corsair Dustin View Post
So just so you guys know, we're aware of this bug, but because of the issues we've seen with H100i/H80i and the current version of C-Link, this has been backburnered to get more pressing problems fixed.
Posted on 03-Nov-2014, over 27 months ago.

Quote:
Originally Posted by Technobeard View Post
If you'd like to report a bug, please respond to this thread.
I have done this for all the CL4 releases and Corsair have not responded to most of these posts. Why is this and why should I bother to report issues?

Here is an itemised list of issues which Corsair failed to respond to or address in a timely manor.
  1. http://forum.corsair.com/forums/showthread.php?p=871675 - CL 4.3.0.154 issues
  2. http://forum.corsair.com/forums/showthread.php?p=864149 - CL 4.2.4.25 issues
  3. http://forum.corsair.com/forums/showthread.php?p=851701 - CL 4.2.3.41 issues
  4. http://forum.corsair.com/forums/showthread.php?p=844974 - CL 4.2.2.27 issues - How do I change the TCP port
  5. http://forum.corsair.com/forums/showthread.php?p=841278 - CL 4.2.1.42 issues
  6. http://forum.corsair.com/forums/showthread.php?p=833499 - CL 4.2.0.162 issues
  7. http://forum.corsair.com/forums/showthread.php?p=892949 - CL4 locking semantics only half fixed.
  8. http://forum.corsair.com/forums/showthread.php?p=833532 - CL asking for a reboot when it should not
  9. http://forum.corsair.com/forums/showthread.php?p=837724 - CL4 using a massive amount of TCP transfers
  10. http://forum.corsair.com/forums/showthread.php?p=833695 - Silly driver package name
  11. http://forum.corsair.com/forums/showthread.php?p=833699 - Issues with > 32 CPUs
  12. http://forum.corsair.com/forums/showthread.php?p=834459 - CL4 does not support CSMI RAID
  13. http://forum.corsair.com/forums/showthread.php?p=836506 - CL4 does not support EC Sensors
  14. http://forum.corsair.com/forums/showthread.php?p=836736 - NVMe Disks are not Reported
  15. http://forum.corsair.com/forums/showthread.php?p=837364 - No support for the original Commander.
  16. http://forum.corsair.com/forums/showthread.php?p=845182 - BSOD caused by Corsair supplied AXi PSU/Asetek Cooler kernel mode driver
  17. http://forum.corsair.com/forums/showthread.php?p=845092 - 10,000 RPM Fans #2 - no reply
  18. http://forum.corsair.com/forums/showthread.php?p=853869 - 10,000 RPM Fans #3 - no reply
  19. http://forum.corsair.com/forums/showthread.php?p=854759 - To fix -ve X and fail to fix -ve Y is incompetent
  20. http://forum.corsair.com/forums/showthread.php?p=839550 - H100iV2 and H100iGTX have different firmware
  21. http://forum.corsair.com/forums/showthread.php?p=850509 - CL4 causing high DPC latencies.
  22. http://forum.corsair.com/forums/showthread.php?p=864164 - CL4 causing high DPC latencies after Corsair claim to have fixed it.
  23. http://forum.corsair.com/forums/showthread.php?p=837228 - CLCC support for 0% PWM or 0 RPM to stop the fans.
Note that some of the entries itemise up to 52 issues and I expect I reported other issues I could add to the list.

Quote:

Attached Images
File Type: png CL 4.5.0.55 still does not have Kaby Lake support.png (160.0 KB, 8052 views)
File Type: png RCK.png (136.1 KB, 6593 views)
File Type: png CPUIDSDK-1.1.5.3-that-comes-with-CAM.png (24.7 KB, 7063 views)

Last edited by red-ray; 03-03-2017 at 07:09 AM. Reason: I got the CPUID SDK fixed + H110i Pump Custom mode


3 members found this post helpful.
  #4  
Old 02-10-2017, 11:37 AM
red-ray red-ray is offline
Banned
red-ray's PC Specs
 
Join Date: May 2014
Location: England (GMT+1)
Posts: 7,152
POST ID # = 890715
red-ray Reputation: 81
Sigh.. Condensed DRAM layout is appropriate, but..

Quote:
Originally Posted by Technobeard View Post
  • Condensed DRAM layout to display modules with the same SPD in one section.
  1. Condensed DRAM layout is appropriate, but should be able to see the whole of BLT4G3D1869DT2TXRG in the title .
  2. Only 7 of my 8 DIMMs are reported . Given we worked out what the issue was in August 2016 and fixed the CPUID SDK for a CL to be released 6 months later and not have the fix shows the CL4 team is incompetent.
  3. How did you decide on the ordering? Please can you explain why this is appropriate?
  4. I suspect the GPUs should also be condensed.
  5. The RM PSUs should be #1 and #2.
  6. As the DIMMs are associated with the CPUs DIMMs should be between the CPUs and GPUs.
Quote:
Attached Images
File Type: png Only 7 of 8 DIMMs and ordering better could be the.png (134.2 KB, 6546 views)

Last edited by red-ray; 03-16-2017 at 04:04 PM. Reason: [QUOTE=Technobeard;890769]


1 members found this post helpful.
  #5  
Old 02-10-2017, 01:04 PM
red-ray red-ray is offline
Banned
red-ray's PC Specs
 
Join Date: May 2014
Location: England (GMT+1)
Posts: 7,152
POST ID # = 890726
red-ray Reputation: 81
Question What is meant to happen when the DIMMs have different SPD information?

Quote:
Originally Posted by Technobeard View Post
  • Condensed DRAM layout to display modules with the same SPD in one section.
I was wondering what is meant to happen when the DIMMs have different SPD information so ran CL 4.5.0.55 on a system with different DIMMs and got as below. There are two screen shots as the name oscillates between the two different DIMM makers which I was not expecting.
  1. This this the intended behaviour?
  2. If not what should it be?
  3. If the flashing is intentional the release notes should specify this as it's rather unusual.
  4. I suspect this has not been tested at all.
  5. The ordering is again unexpected.

Quote:
Attached Images
File Type: png RXD-Micron.png (94.0 KB, 6528 views)
File Type: png RXD-Samsung.png (95.3 KB, 6543 views)

Last edited by red-ray; 02-22-2017 at 02:00 AM. Reason: [QUOTE=Technobeard;890769]


1 members found this post helpful.
  #6  
Old 02-10-2017, 02:41 PM
red-ray red-ray is offline
Banned
red-ray's PC Specs
 
Join Date: May 2014
Location: England (GMT+1)
Posts: 7,152
POST ID # = 890732
red-ray Reputation: 81
Angry The interlocking semantics are still incorrect in CL 4.5.0.55

Quote:
Originally Posted by Technobeard View Post
  • Performance and stability improvements, minor bug fixes
Quote:
Originally Posted by gilad215 View Post
[*]Performance and stability improvements, minor bug fixes ?????
You are wise to question if anything has been fixed as at least one trivial but important fix has either not been done or incorrectly done.

The interlocking semantics are still incorrect. I expect the fix is to interpose the OpenFile() and AcquireLock() calls to adhere to the specification at the top of page 4 of the Corsair Link Lock Library documentation that is AcquireLock() should be done before the OpenFile().

Quote:
Originally Posted by red-ray View Post
The interlocking semantics are still incorrect and given I reported this on 09-Aug-2016 why? I also e-mailed the product manager who did not even reply to my e-mail. I suspect it's a one line change and can be tested using SIV 5.12 which typically reports the issue in < 2 seconds.

Last edited by red-ray; 02-11-2017 at 02:33 AM. Reason: [QUOTE=Technobeard;890769]


1 members found this post helpful.
  #7  
Old 02-10-2017, 11:13 PM
hhh2260 hhh2260 is offline
Registered User
 
Join Date: Feb 2017
Posts: 1
POST ID # = 890783
hhh2260 Reputation: 10
Default

1. Version of your Link software: 4.5.0.55
2. What version of Windows you're using: Win10 64bit
3. Summary - One line / sentence explaining the issue:
Vengeance LED ram not working on Asus Z270E MOBO and 7700K

I used the previous version. At least one lane of the ram can be controlled and it worked fine. Now I updated CL there is no LED option at all and neither of the ram LEDs work.
Attached Images
File Type: png CL.PNG (320.1 KB, 6487 views)


1 members found this post helpful.
  #8  
Old 02-11-2017, 12:08 AM
fher fher is offline
Registered User
fher's PC Specs
 
Join Date: Feb 2017
Location: México
Posts: 1
POST ID # = 890787
fher Reputation: 10
Default Corsair Link does not recognize Intel Kaby Lake Processor

1. Corsair Link v4.5.0.55
2. Windows 10
3. Corsair Link does not recognize Intel Kaby Lake 7700k Processor temperature
4. The software does not show the mother board, cores and RAM. I tried with diffferent versions, reinstallation and i got the same result. It seems that the library cpuidsdk.dll is outdated.
5.
Attached Images
File Type: jpg Captura.JPG (193.1 KB, 204 views)


1 members found this post helpful.
  #9  
Old 02-11-2017, 12:37 AM
Marmite_II Marmite_II is offline
Registered User
Marmite_II's PC Specs
 
Join Date: Jan 2017
Posts: 81
POST ID # = 890789
Marmite_II Reputation: 10
Default

Hi Corsair Fans

1) Corsair Link v4.5.0.55
2) Win10 Pro 64bit
3) Corsair Link does not recognize Intel Kaby Lake 7700k Processor temperature
4) No Kaby Lake 7700k CPU support?
5) Z270 chipset

I really don't know what link-software should show or not?
Attached Images
File Type: jpg Link.jpg (151.0 KB, 195 views)


1 members found this post helpful.
  #10  
Old 02-11-2017, 02:49 AM
red-ray red-ray is offline
Banned
red-ray's PC Specs
 
Join Date: May 2014
Location: England (GMT+1)
Posts: 7,152
POST ID # = 890794
red-ray Reputation: 81
Sigh.. Specify which motherboard

Quote:
Originally Posted by fher View Post
4. The software does not show the mother board, cores and RAM. I tried with diffferent versions, reinstallation and i got the same result. It seems that the library cpuidsdk.dll is outdated.
You should specify which motherboard, better still add your full PC specs to your profile as specified in http://forum.corsair.com/forums/showthread.php?t=77167

A later cpuidsdk.dll will fix the Kaby Lake reporting, but may not address the motherboard. I advise you to check what HWM reports and if needed work with the HWM/CPUIDSDK developers to get support for your motherboard added to HWM. This will mean an even later cpuidsdk.dll will be able to report your motherboard.

Last edited by red-ray; 02-11-2017 at 06:08 AM.


  #11  
Old 02-11-2017, 02:54 AM
red-ray red-ray is offline
Banned
red-ray's PC Specs
 
Join Date: May 2014
Location: England (GMT+1)
Posts: 7,152
POST ID # = 890795
red-ray Reputation: 81
Arrow Of course it should report the Kaby Lake

Quote:
Originally Posted by Marmite_II View Post
I really don't know what link-software should show or not?
Of course it should report the Kaby Lake core temperatures and as I showed in my earlier post it would if Corsair shipped a later CPUIDSDK with it.


  #12  
Old 02-11-2017, 03:15 AM
red-ray red-ray is offline
Banned
red-ray's PC Specs
 
Join Date: May 2014
Location: England (GMT+1)
Posts: 7,152
POST ID # = 890798
red-ray Reputation: 81
Question What Revision are your DIMMs?

Quote:
Originally Posted by hhh2260 View Post
Vengeance LED ram not working on Asus Z270E MOBO and 7700K

I used the previous version. At least one lane of the ram can be controlled and it worked fine. Now I updated CL there is no LED option at all and neither of the ram LEDs work.
I get the same effect so it's useful to know it not just me that get's the issue.

Quote:
Originally Posted by red-ray View Post
2. It's also totally failing to report the 2 x Corsair Vengeance LED modules
I am wondering if it's just the LED revision 0x03 DIMMs that aren't reported. Please will you run my SIV utility and post the [SPD] + [SMB Bus] panels so I can check? On my system with revision 0x03 LEDs I get as below.

If anyone reading this has LED DIMMs that CL 4.5.0.55 does report please will you post the above two panels so I can try and deduce why.

BTW You should add yourl PC specs to your profile

Quote:

Attached Images
File Type: png [SMB Bus]CMU16GX4M2A2666C16 Revision 0x03.png (67.1 KB, 6377 views)
File Type: png [SPD Summary]CMU16GX4M2A2666C16 Revision 0x03.png (53.6 KB, 6376 views)

Last edited by red-ray; 02-21-2017 at 07:31 AM.


  #13  
Old 02-11-2017, 07:16 PM
PrEzi PrEzi is offline
Registered User
PrEzi's PC Specs
 
Join Date: Mar 2015
Posts: 5
POST ID # = 890904
PrEzi Reputation: 10
Default

Wow... just WOW!
I've given up on Corsair. I'll never buy or recommend a product from them again.
Made a mistake once. Shame on me.


  #14  
Old 02-12-2017, 08:05 AM
BipolarBear's Avatar
BipolarBear BipolarBear is offline
Registered User
BipolarBear's PC Specs
 
Join Date: Aug 2014
Location: London UK
Posts: 24
POST ID # = 890970
BipolarBear Reputation: 18
Default

I think Corsair Link as a device is becoming redundant anyway. Look at all the new motherboards: 6+ pwm fan headers, 1 or even 2 rgb headers, plus multiple temp sensors... my next upgrade CL will be coming out of my system and never going back in.


  #15  
Old 02-12-2017, 08:43 AM
fyew-jit-tiv fyew-jit-tiv is offline
Registered User
 
Join Date: Nov 2009
Posts: 64
POST ID # = 890974
fyew-jit-tiv Reputation: 10
Default

Has commandline support been added to this revision?


Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:09 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.