The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 06-28-2017, 11:21 AM
Zantho Zantho is offline
Registered User
Zantho's PC Specs
 
Join Date: Jun 2017
Location: Buenos Aires
Posts: 2
POST ID # = 909770
Zantho Reputation: 10
Default K55 RGB - update failed

I recently purchased this keyboard. The first time I connected the device to my computer worked well, the lights went on and I could use the effects combinations. But then I opened the CUE and asked me to update the firmware and it stopped working, it shows an "update error" message and the K55 image in the software dissapear.

The keypad is off and only flashing the white top-right lights.

I changed USB ports, uninstalled the drivers, but still not working.

Can I install the new firmware without the need for the CUE?
Reply With Quote


  #2  
Old 06-30-2017, 02:53 PM
Greybeard's Avatar
Greybeard Greybeard is offline
Corsair Employee
 
Join Date: Feb 2012
Location: Corsair HQ
Posts: 1,317
POST ID # = 910004
Greybeard Reputation: 24
Default

Try holding the FN + F4 while the KB is plugged in. The KB will flash then light up. Then try to flash the FW again via CUE.
Reply With Quote


  #3  
Old 07-04-2017, 10:20 AM
Zantho Zantho is offline
Registered User
Zantho's PC Specs
 
Join Date: Jun 2017
Location: Buenos Aires
Posts: 2
POST ID # = 910343
Zantho Reputation: 10
Default

Quote:
Originally Posted by Greybeard View Post
Try holding the FN + F4 while the KB is plugged in. The KB will flash then light up. Then try to flash the FW again via CUE.
Not work yet.

But I conect the keyboard in another computer, and i can fix it.

The problem now is with te "rainbow" and "change/pulse color" effects...
the keyboard connect and disconnect every 10 seconds, only work in static mode
Reply With Quote


  #4  
Old 07-05-2017, 03:06 PM
Greybeard's Avatar
Greybeard Greybeard is offline
Corsair Employee
 
Join Date: Feb 2012
Location: Corsair HQ
Posts: 1,317
POST ID # = 910454
Greybeard Reputation: 24
Default

Have you done any updates on your USB drivers? It's probably related to your USB interface.
Reply With Quote


Reply

Tags
error, firmware, k55, update, white ligths

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 04:00 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.