The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 12-25-2016, 01:50 AM
Siman Siman is offline
Registered User
Siman's PC Specs
 
Join Date: Dec 2016
Posts: 2
POST ID # = 883685
Siman Reputation: 10
Default Corsair Void Wireless Problems Found

OK... So I decided to leap into my Corsair VOID Wireless graphite to see what the issues Im having and everyone else is having...

What I found was a bit appalling from an audio person's point of view... The soldering points are botched mostly signs of under heated contact points. They also are using a piece of tape to hold the audio cables in place needless to say not a good thing. A majority of the poping problems could be fixed with the tape issue alone. Another issue I found is the battery is held in the far side of the head set and the cables that carry audio to the other headset ride in the same cable as the power... Back onto the cables, again... they are very poorly shielded and undersized. For a headset that cost this much Im very, very displeased. I suggest people that want a good headset look elsewhere this is a very poor product, also something I did not expect coming from corsair.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 03:27 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.