The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 11-20-2019, 11:33 AM
canapi canapi is offline
Registered User
canapi's PC Specs
 
Join Date: Jun 2012
Location: Italy
Posts: 9
POST ID # = 1024579
canapi Reputation: 10
Default Void PRO Usb Mic perma Off Issue

I have this strange problem since I updated iCue software, if i unplug my Void Headset after replug mic seems on but switching off from the headset button i ear the Voice feedback (Mike off) then it's impossible to switch on again, no feedback, led always red and mic not working (Audio it's ok).
So I have to unload iCue, start again the iCue Application and the headset now works ok, until I unplug the USB cable.

Any suggestion?
Reply With Quote


  #2  
Old 11-21-2019, 07:32 AM
canapi canapi is offline
Registered User
canapi's PC Specs
 
Join Date: Jun 2012
Location: Italy
Posts: 9
POST ID # = 1024697
canapi Reputation: 10
Default

I tried all the workarounds listed in the support page but nothing fixed the problem, any news about a new release of the iCUe software that will fix this issue?
Reply With Quote


  #3  
Old 11-28-2019, 06:10 AM
canapi canapi is offline
Registered User
canapi's PC Specs
 
Join Date: Jun 2012
Location: Italy
Posts: 9
POST ID # = 1025509
canapi Reputation: 10
Default

Ok, seems there is no update on software, i'll try to send a customer request directly to corsair, headset still not working at all and starting icue again everytime i unplug the headset it's really annoying
Reply With Quote


  #4  
Old 12-03-2019, 03:55 AM
canapi canapi is offline
Registered User
canapi's PC Specs
 
Join Date: Jun 2012
Location: Italy
Posts: 9
POST ID # = 1026088
canapi Reputation: 10
Default

I opened a Ticket with customer support and they asked me to uninstall and re-install iCue but the problem still exists, anyone have resolved and can help me to manage this issue?
If I close ICue the mic works fine, when I start Icue all seems to work but if I unplug and re-plug the Void USB Pro the mic remain in Off status even if by software I enable and disable it, so I gave to unload and reload iCue to enable the mic again.

Tnx

Last edited by canapi; 12-03-2019 at 03:58 AM.
Reply With Quote


  #5  
Old 12-05-2019, 09:08 AM
canapi canapi is offline
Registered User
canapi's PC Specs
 
Join Date: Jun 2012
Location: Italy
Posts: 9
POST ID # = 1026368
canapi Reputation: 10
Default

After 2 weeks of no answer from corsair I decided to request a refund for the defective headset. and from now on I'll no more buy corsair products.. so poor customer support for the highest prices in the market.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 03:22 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.