The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 08-16-2019, 09:03 PM
Celt1 Celt1 is offline
Registered User
Celt1's PC Specs
 
Join Date: Dec 2015
Posts: 23
POST ID # = 1014895
Celt1 Reputation: 13
Default Strafe fail with Crosshair VI Hero - Firmware the problem!

A 3900x is arriving tomorrow, so I tried flashing my Crosshair VI Hero bios to versions 7401 and then 7306, both gave me a problem I have never experienced before. On the initial boot I get to the press F1 screen to enter bios. Unfortunately, my Corsair Strafe RGB keyboard has the Scroll Lock key blinking, and none of the keys function. At that point I am just "stuck".

The only workaround is to plug in an old Microsoft USB keyboard I had around, which works ok. After entering bios, then saving, exiting, I can go back to the Strafe and boot into Windows and things work. However, I can not get back to bios, as the same bad behavior repeats (pressing Del key won't work)until it boots windows. The only way to access the bios is with the Microsoft keyboard.

I googled blinking Scroll Lock key on a Strafe and I see where that means something about "bios mode" of the keyboard and to press a combo of F1 and the upper right Windows key, but this does not solve the issue.

Anyone else had this weird problem?

Last edited by Celt1; 08-18-2019 at 04:23 PM. Reason: Update
Reply With Quote


  #2  
Old 08-18-2019, 04:20 PM
Celt1 Celt1 is offline
Registered User
Celt1's PC Specs
 
Join Date: Dec 2015
Posts: 23
POST ID # = 1015033
Celt1 Reputation: 13
Default

I found a temporary workaround. I downloaded an old firmware version for the Strafe, and flashed it to the keyboard in iCue. Version 2.05. Then I rebooted and though it still has the scroll lock white indicator blinking, I could then hit the del key to bring up the Bios splash screen, and the F1 key worked to enter Bios.

I then went back to Windows, "upgraded the firmware" to the current version, and bam! The keyboard once again fails to function to get in to the bios. I had to revert firmware once again to make it work.

Clearly, something in the new firmware breaks the keyboard in terms of pre-Windows boot process with this motherboard.
Reply With Quote


  #3  
Old 08-21-2019, 04:23 AM
Xelosu Xelosu is offline
Registered User
 
Join Date: Nov 2015
Posts: 7
POST ID # = 1015308
Xelosu Reputation: 10
Default

I have similar problem on my Strafe RGB on ASUS ROG STRIX X570-F GAMING
running Bios version 0804.

On top of this issue my keybord seems to ignore settings regarding static backlight, no matter what I do. If I force flashe the update of firmware the issue goes away but only till next boot up where the issue re-occurs.

Last edited by Xelosu; 08-21-2019 at 04:58 AM.
Reply With Quote


  #4  
Old 08-24-2019, 09:12 PM
Celt1 Celt1 is offline
Registered User
Celt1's PC Specs
 
Join Date: Dec 2015
Posts: 23
POST ID # = 1015630
Celt1 Reputation: 13
Default

Quote:
Originally Posted by Xelosu View Post
I have similar problem on my Strafe RGB on ASUS ROG STRIX X570-F GAMING
running Bios version 0804.

On top of this issue my keybord seems to ignore settings regarding static backlight, no matter what I do. If I force flashe the update of firmware the issue goes away but only till next boot up where the issue re-occurs.
Well I finally gave up! I bought a Steelseries Apex 7 TKL, and the problems disappeared. Side benefit is no more Icue software to hassle with.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 12:48 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.