The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Cooling

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 07-23-2015, 11:42 PM
Zwaluu Zwaluu is offline
Registered User
Zwaluu's PC Specs
 
Join Date: Jul 2015
Posts: 5
POST ID # = 791094
Zwaluu Reputation: 10
Question H100i GTX not showing up in Link?

So I recently bought and installed the H100i GTX for my computer and then proceeded to download the Corsair Link, however the cooler is not present in Corsair Link. Looking in device manager shows me that the cooler is listed as 'H100iGTX Cooler' in 'Other devices'. I've read somewhere else that during the Corsair Link install it should have prompted me to install a certain hydro driver. It did not do this for me. Checking for Updates through Corsair Link says it does not detect any devices that need updates. I've tried reinstalling Corsair Link multiple times now but it doesn't work. I've been installing version 3.1.5667.

Last edited by Zwaluu; 07-23-2015 at 11:43 PM. Reason: added corsair version number
Reply With Quote


  #2  
Old 07-24-2015, 04:33 AM
red-ray red-ray is offline
Banned
red-ray's PC Specs
 
Join Date: May 2014
Location: England (GMT+1)
Posts: 7,152
POST ID # = 791106
red-ray Reputation: 81
Default

In Windows Device manager do Update Driver for the 'H100iGTX Cooler'. After doing this post the properties panel and/or any error report panels.

The CL installation should do this automatically and Corsair need to fix it to do so.

Last edited by red-ray; 07-24-2015 at 09:12 AM.
Reply With Quote


  #3  
Old 07-24-2015, 03:27 PM
Zwaluu Zwaluu is offline
Registered User
Zwaluu's PC Specs
 
Join Date: Jul 2015
Posts: 5
POST ID # = 791187
Zwaluu Reputation: 10
Default

When I try to update I get this
"Windows was unable to install your H100iGTX Cooler

Windows could not find driver software for your device.
If you know the manufacturer of your device, you can visit it's website and check the support section for driver software"

Properties just says there's no driver installed

"The drivers for this device are not installed. (Code 28)

There is no driver selected for the device information set or element

To find a driver for this device, click Update Driver"

Last edited by Zwaluu; 07-24-2015 at 03:32 PM.
Reply With Quote


  #4  
Old 07-24-2015, 04:07 PM
Stolly08 Stolly08 is offline
Registered User
Stolly08's PC Specs
 
Join Date: Jul 2015
Posts: 1
POST ID # = 791190
Stolly08 Reputation: 10
Default

I had an issue with mine as well! It wouldn't show the LED color thing nor the pump speed and it wasn't running the fans very well at all.... Tried using a different usb cable and all... To no avail I took it out and went back to Micro Center and replaced it and hooked everything up and turned it on and viola! Pump color settings and the pump speed monitor was there as well! So I'd say they probably had a bad batch or something from the factory... I'd recommend going to get a new one. GL!
Reply With Quote


  #5  
Old 07-24-2015, 04:43 PM
red-ray red-ray is offline
Banned
red-ray's PC Specs
 
Join Date: May 2014
Location: England (GMT+1)
Posts: 7,152
POST ID # = 791201
red-ray Reputation: 81
Default

Have a look at http://forum.corsair.com/forums/showthread.php?p=791175 and check the drivers are there on your system.

If they aren't then install/reinstall CL 3.1.5667 until they are. I feel installing from C:\Program Files (x86)\Silabs\MCU\USBXpress2\ is likely to cause more problems as it solves.

Last edited by red-ray; 07-25-2015 at 04:50 AM. Reason: If they aren't then install/reinstall CL 3.1.5667
Reply With Quote


  #6  
Old 07-24-2015, 06:34 PM
Zwaluu Zwaluu is offline
Registered User
Zwaluu's PC Specs
 
Join Date: Jul 2015
Posts: 5
POST ID # = 791242
Zwaluu Reputation: 10
Default

It's not in the list for me, in fact there is nothing in there from Corsair.
Reply With Quote


  #7  
Old 07-25-2015, 02:19 AM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 19,344
POST ID # = 791294
Toasted Toasted Reputation: 108
Default

If there is nothing listed from Corsair in the drivers selection menu, as red-ray mentioned reinstall the LINK software as it should automatically install the drivers.

If you still don't get it, go to C:\Program Files (x86) and see if a Silabs folder is there.
Reply With Quote


  #8  
Old 07-25-2015, 03:13 PM
Zwaluu Zwaluu is offline
Registered User
Zwaluu's PC Specs
 
Join Date: Jul 2015
Posts: 5
POST ID # = 791395
Zwaluu Reputation: 10
Default

I reinstalled Link, still did not pop up and it's still know as H100iGTX Cooler in other devices. There IS a Silabs folder in C:\Program Files(x86).
Reply With Quote


  #9  
Old 07-26-2015, 08:33 AM
GO302LX's Avatar
GO302LX GO302LX is offline
Registered User
GO302LX's PC Specs
 
Join Date: Jun 2015
Posts: 28
POST ID # = 791493
GO302LX Reputation: 29
Default H100i GTX not showing up in Link?

I find it odd, Corsair has not updated the link to new CL version 3.1.5667 on H100i GTX site http://www.corsair.com/en-us/hydro-s...uid-cpu-cooler. 3.1.5570 is only option to download. The drivers installed correctly from version 3.1.5570 on my system. Plan on setting up CL one time and then never use its GUI without running the risk of it crashing. http://forum.corsair.com/v3/showthread.php?t=142031
Reply With Quote


  #10  
Old 07-26-2015, 08:43 AM
red-ray red-ray is offline
Banned
red-ray's PC Specs
 
Join Date: May 2014
Location: England (GMT+1)
Posts: 7,152
POST ID # = 791496
red-ray Reputation: 81
Arrow I recommend using CL v3.1.5667

Quote:
Originally Posted by GO302LX View Post
I find it odd, Corsair has not updated the link to new CL version 3.1.5667 on H100i GTX site http://www.corsair.com/en-us/hydro-s...uid-cpu-cooler. 3.1.5570 is only option to download.
Corsair claim the only change from 3.1.5570 to 3.1.5667 is to add H110iGTX support and it's only needed if you have a H110iGTX.

When I checked I found they had also fixed the locking and posted http://forum.corsair.com/forums/showthread.php?p=790485.

Quote:
Originally Posted by red-ray View Post
I am keeping my fingers crossed that the locking is correctly implemented and recommend only using CL v3.1.5667 rather than the earlier CL 3.1 releases.
Reply With Quote


  #11  
Old 07-26-2015, 09:17 AM
GO302LX's Avatar
GO302LX GO302LX is offline
Registered User
GO302LX's PC Specs
 
Join Date: Jun 2015
Posts: 28
POST ID # = 791505
GO302LX Reputation: 29
Default

With Windows 10 soon to be released along with New Corsair Hydro units being released.
I will wait for new SIV version as a controller. With or without the Eye Candy.
Reply With Quote


1 members found this post helpful.
  #12  
Old 07-27-2015, 11:55 AM
Corsair Dustin's Avatar
Corsair Dustin Corsair Dustin is offline
Corsair Employee
Corsair Dustin's PC Specs
 
Join Date: Oct 2013
Posts: 4,100
POST ID # = 791712
Corsair Dustin Reputation: 41
Default

There is a vastly improved version of CL3 in the pipe and due before the month is out, and CL4 is going to be out not too long after that. Both are compatible with Windows 10.
__________________
Corsair DIY & Gaming Systems Architect
Product Manager for Cooling


Please do not send private messages requesting tech support or trouble shooting. You can create a thread and let the solution to your issue be visible to everyone, or alternatively, work directly with tech support by contacting them here.
Reply With Quote


  #13  
Old 07-28-2015, 12:05 AM
Zwaluu Zwaluu is offline
Registered User
Zwaluu's PC Specs
 
Join Date: Jul 2015
Posts: 5
POST ID # = 791861
Zwaluu Reputation: 10
Default

So... anyone has any ideas? Do I do anything with the Silabs folder?
Reply With Quote


Reply

Tags
h100i, h100i gtx, issues, link, not working

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:47 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.