The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 11-04-2016, 05:51 PM
Xebeche Xebeche is offline
Registered User
Xebeche's PC Specs
 
Join Date: Dec 2013
Posts: 11
POST ID # = 877992
Xebeche Reputation: 10
Default Issues with CUE & USB Pass-Through Plug

I have a K70 RGB (received it a while ago when my previous Corsair keyboard was replaced after exhibiting the first issue below, but only just started using it).

I’ve noticed several problems, and I’m using CUE 2.6.70, but I also experimented with version 1.16.42 and had / have similar issues.

1) The keyboard seems to work, but sometimes after waking my PC from sleep, I notice the lighting isn’t what I intended. Checking CUE, it says it can’t find the device. A restart corrects this until it happens again.

2) Even though this keyboard doesn’t have a USB pass-through, there are two USB plugs. When I connect them both, my Device Manager shows “Unknown USB Device (Device Descriptor Request Failed)”

3) CUE 2.6.70 generates an error when checking for updates. I believe I read elsewhere in the forum that this is beta software and the update portion isn’t working yet. That’s not great, but what I find a bit more irritating is that, without actually searching, I had no idea this wasn’t a release version. The download page doesn’t say it's a beta unless I missed it somehow.

Any suggestions / help would be appreciated.
Reply With Quote


  #2  
Old 11-04-2016, 06:20 PM
terabyte's Avatar
terabyte terabyte is offline
CORSAIR Beta Team
terabyte's PC Specs
 
Join Date: Sep 2014
Location: Italy
Posts: 4,354
POST ID # = 877993
terabyte Reputation: 73
Default

1) Several peoples already mentioned this issue, Corsair is improving on it with each release though.

2) You only need both cables in case you are using 2 x USB 2.0 ports, if you are using USB 3.0 just plug in the cable with the keyboard on it. The other cable is used for additional power when using USB 2.0. If you are using USB 3.0 and plugging them both in, that might explain the error you are seeing in the device manager.

3) 2.6.70 is a stable release, CUE 2 has been released as stable since 2.4. However CUE 2 is still quite a new version and they want to improve it more in these first releases. The update checker is still setup for CUE 1.x only until they improve CUE 2 further with the feedback from the first releases.


You can find the CUE 2.x open beta forum here for further questions about it: http://forum.corsair.com/v3/forumdisplay.php?f=276 - And yes, even thought it is called open beta, the software is a stable release at this point as I already mentioned above.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 08:16 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.