The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 11-13-2017, 07:21 AM
3xChester_exe 3xChester_exe is offline
Registered User
3xChester_exe's PC Specs
 
Join Date: Nov 2017
Posts: 1
POST ID # = 926150
3xChester_exe Reputation: 10
Sad My K70 LUX RGB suddenly not working

Hi there, today I got... kinda unfix-able problem to me. Where the issue is those 3 white LEDS (Num lock, caps lock, scroll lock) are lit. But all keys are not working and lighting effect are also no go. Previously it was working fine but after I restart my PC. This happens. Also, CUE also didn't detect my keyboard because of this too (Using the latest version of CUE), Only got DEMOS. When I plugged in the USB, my PC gives me a sound like usb has been plugged in. I got the pic so is easy for you guys to assist me or see what i'm trying to say

Pics : https://imgur.com/XCE5UCt

P/S: I already tried multiple way to fix this.. Including soft reset, reinstall drivers/CUE software or use the older version, test it on different pc/laptop. Some said it was firmware failure, but my CUE unable to detect my keyboard until now, not even the soft reset method. Still cannot make my keyboard working as usual again. I really need my keyboard alive again for my daily typing workload. Also, Sorry for my bad English.

Last edited by 3xChester_exe; 11-13-2017 at 07:38 AM.
Reply With Quote


  #2  
Old 11-13-2017, 01:58 PM
Corsair Nick's Avatar
Corsair Nick Corsair Nick is offline
Corsair Employee
 
Join Date: Feb 2016
Posts: 947
POST ID # = 926191
Corsair Nick Reputation: 39
Default

You can try performing a hard firmware reset to revive the keyboard. Submit a ticket on the support site, and one of our Technical Support staff can provide you with the appropriate firmware files.

https://support.corsair.com/
Reply With Quote


  #3  
Old 11-05-2019, 03:35 AM
Spazu Spazu is offline
Registered User
 
Join Date: Nov 2019
Posts: 1
POST ID # = 1023072
Spazu Reputation: 10
Default Same probem

i am currently having the same issue.was this fixable?
Reply With Quote


  #4  
Old 11-05-2019, 11:41 AM
Laxbouas Laxbouas is offline
Registered User
 
Join Date: Nov 2019
Posts: 2
POST ID # = 1023110
Laxbouas Reputation: 10
Default

Yes seems to be my issue as well. Except my K70 board and M65 mouse worked fine for months then all of a sudden they light up with white light that seems to dim and pulse at random. Like a lose connection well I tried moving it and on different computer same issue. I open up cue and it says there is firmware updates. I try to download them and it throws me update failed. Kicker of it is that my settings come back after a while then go away again. Like currently my mouse started to light up correctly while typing this and my keyboard still dead.
Reply With Quote


  #5  
Old 11-05-2019, 11:42 AM
Laxbouas Laxbouas is offline
Registered User
 
Join Date: Nov 2019
Posts: 2
POST ID # = 1023112
Laxbouas Reputation: 10
Default edit

Que doesn't even detect my devices also
Reply With Quote


  #6  
Old 11-05-2019, 05:32 PM
Corsair Nick's Avatar
Corsair Nick Corsair Nick is offline
Corsair Employee
 
Join Date: Feb 2016
Posts: 947
POST ID # = 1023156
Corsair Nick Reputation: 39
Default

Go ahead and put in a support ticket and request a hard firmware reset. This should help to bring the devices back to life:

https://support.corsair.com/
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:36 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.