The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Notices

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 09-25-2019, 10:28 PM
Veralius Veralius is offline
Registered User
 
Join Date: Sep 2019
Posts: 1
POST ID # = 1019290
Veralius Reputation: 10
Default Games/Computer Lags When Mouse Moves Fix (Polling Rate)

This post is for people having the problem of game/computer lag when moving their mouse. My problem was in certain games and very noticeable in file explorer.

When I finally upgraded my computer to an i9 9900k CPU and RTX 2070 GPU I was shocked to find my computer lag when running my game at little to no frame rate when my mouse was moving (I use the Scimitar RGB). I started by closing applications to see if there was an issue with one of them and I figured out it was an iCue problem. After more digging I found out it has to do with the polling rate option in iCue.

After reducing it from the 1000hz/1ms to the minimum my games were playable but still some hitching. However, my issue of a slow file explorer still continued and would only fully go away if I completely closed iCue. My way less powerful computer (i7 7700k and GTX 970) ran no problem despite the same polling rate. I could tell it was a huge problem because the graphics previewer in the Nvidia control panel would come to a complete stop when I ran my mouse back and forth on it at 1000hz/1ms polling rate.

I did some digging and I have finally found the fix to my problem from a hint on another forum. The problem seems to be a polling rate compatibility? problem with the Z390 chipset. I have the ASRock Z390 Phantom Gaming 4 MoBo so the poster might have been on to something. If you go into the BIOS, go to the CPU Configuration section and disable the C-State options the problem totally cleared up. But I didn’t like the idea of shutting off all the C-States at all times and found out (at least for me) my problem completely went away when I turned off the C3 state specifically.

I wanted to post this because I could not for the life of me find a solution to this anywhere but I hope this helps someone. Thanks.

TL:DR - If polling rate is causing a lot of issues for you and you have a Z390 chipset MoBo, try turning off all C-states/just the C3 state and see if it works for you.
Reply With Quote


  #2  
Old 11-11-2019, 04:56 PM
Snappera Snappera is offline
Registered User
 
Join Date: Jan 2017
Posts: 8
POST ID # = 1023655
Snappera Reputation: 10
Default

Did you find it increased your power usage?

I think it's something to do with the AsRock Z390 Motherboards, honestly. Everyone with an issue has some form of AsRock Z390. I'm seriously considering ditching AsRock and buying a new motherboard. Just going to be a pain reformatting my PC for the new MoBo :(
Reply With Quote


Reply

Tags
polling, rate

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:12 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.