The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > iCUE Software

Notices

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 03-29-2019, 01:14 PM
DemonRoxas DemonRoxas is offline
Registered User
DemonRoxas's PC Specs
 
Join Date: Mar 2018
Posts: 20
POST ID # = 999448
DemonRoxas Reputation: 10
Woah! iCUE makes Desktop flicker on GSync enabled FreeSync Monitors

I was able to reproduce this error with two different systems.

When using a FreeSync monitor with an NVidia GPU running in GSync compatibility mode, the desktop starts flickering when you open up iCUE. No other program or software causes this issue. Once you close iCue or refocus to another application, the flickering stops.

Weird.
Reply With Quote
  #2  
Old 03-29-2019, 06:07 PM
Corsair Calico Jack's Avatar
Corsair Calico Jack Corsair Calico Jack is offline
Corsair Employee
 
Join Date: Oct 2016
Posts: 588
POST ID # = 999474
Corsair Calico Jack Reputation: 10
Default

Gsync just doesn't react well to the type of UI iCUE uses. You can set Gsync in the Nvidia Control panel to only run when the program is fullscreen. That will make the issue go away while still allowing Gsync to function.
Reply With Quote
  #3  
Old 09-14-2019, 03:53 PM
Bailey125 Bailey125 is offline
Registered User
 
Join Date: Sep 2019
Posts: 1
POST ID # = 1018209
Bailey125 Reputation: 10
Default

(Sorry for replying 6 months later) Can also confirm this. Even clicking on iCUE in system tray to bring up the little menu also causes this.
Reply With Quote
  #4  
Old 09-14-2019, 05:14 PM
c-attack c-attack is online now
Registered User
c-attack's PC Specs
 
Join Date: Jun 2014
Posts: 12,344
POST ID # = 1018216
c-attack c-attack Reputation: 122
Default

You don't want your screen running in GSync windowed mode or it will do this with any application that uses GPU resources. "Full Screen Only" is the best set up for most people, but if you actually play stuff in Windowed mode, you can use the Nvidia Control Panel to make specific settings for iCUE to turn it Gsync off when that window is in focus.
Reply With Quote
  #5  
Old 02-23-2020, 02:05 PM
pandadog pandadog is offline
Registered User
pandadog's PC Specs
 
Join Date: Feb 2020
Posts: 1
POST ID # = 1035821
pandadog Reputation: 10
Default

Sorry about replying after a few months, but how you go about making those changes if you dont mind explaining?
Reply With Quote
  #6  
Old 02-23-2020, 06:50 PM
c-attack c-attack is online now
Registered User
c-attack's PC Specs
 
Join Date: Jun 2014
Posts: 12,344
POST ID # = 1035845
c-attack c-attack Reputation: 122
Default

For general Full Screen only vs Windowed/Full Screen mode, open the Nvidia Control Panel. Under the display section, select "Set-up G-SYNC". That is the only option there.

If you need to use Windowed Gsync mode, then you might want to deactivate it for the individual application. Nvidia Control Panel -> Manage 3D settings. Select the program tab and select or add the program (iCUE.exe). Go down to monitor technology and change if from the default follow global (Gsync ON) to "fixed refresh rate". That will turn it off when iCUE is in focus. Be aware this is an issue in Windowed mode for any app that uses GPU acceleration. You may have the same problem with Steam, Mystic Light, or anything else like it. I find it easier to turn Widowed Gsync on/off for the one game I need it rather than exclude the dozen or so that will not react well.
Reply With Quote
  #7  
Old 02-23-2020, 07:18 PM
eugen eugen is offline
Registered User
 
Join Date: Aug 2019
Posts: 7
POST ID # = 1035851
eugen Reputation: 10
Default

my monitor doesn't even support gsync (but freesync)
icue is the only application doing this nasty flickering

would corsair mind and kindly fix this ?
Reply With Quote
  #8  
Old 02-23-2020, 08:38 PM
c-attack c-attack is online now
Registered User
c-attack's PC Specs
 
Join Date: Jun 2014
Posts: 12,344
POST ID # = 1035860
c-attack c-attack Reputation: 122
Default

Quote:
Originally Posted by eugen View Post
my monitor doesn't even support gsync (but freesync)
icue is the only application doing this nasty flickering

would corsair mind and kindly fix this ?
Then do the same things through your on end. It's not a Corsair problem to fix. It's how the tech works. You want Free Sync to selectively apply itself in different way to different apps? Set it up.
Reply With Quote
  #9  
Old 02-25-2020, 04:44 PM
rascaluk rascaluk is offline
Registered User
rascaluk's PC Specs
 
Join Date: Jan 2019
Location: UK
Posts: 39
POST ID # = 1036045
rascaluk Reputation: 10
Default

Quote:
Originally Posted by c-attack View Post
Then do the same things through your on end. It's not a Corsair problem to fix. It's how the tech works. You want Free Sync to selectively apply itself in different way to different apps? Set it up.
(edited for typos)

I hear you.

However, I think there are clearly compatibility issues going on between Corsair iCue and Nvidia Drivers/GeForce Experience. It means users have to manage the issues themselves; disabling things, creating custom exclusions etc. Now, you're right, the control to work around these issues may be in the Nvidia software, but I don't think it should really be this way.

Taking this a step further...Corsair chose to build the iCue tool with a modern, grphic accelerated UI. Then, the prevailing advice is to deal with issues in the Nvidia software - they chose this path. They chose to have their software have to keep pace with major windows 10 changes to graphics rendering, and progression of Nvidia drivers and GeForce Experience.

I'm tired of hearing the same unofficial, though well meaning voices on this forum say "I have g-sync but don't have a problem - must be something else" etc., which to me, completely misses the point and ignores the fact there are many other variables out there...variables that Corsair and Nvidia should work together to resolve.

As a perfect example, in the last update or so for GeForce Experience, the Nvidia Overlay started rendering the FPS in the iCue UI, despite exlusions being in place in Nvida control panel, despite disabling windowed mode for g-sync. It does this because it now recognises iCue as game. It happened to Wallpaper Engine too, resulting in the devs having to reach out to Nvidia.

So...honestly, I think if Corsair have chosen to have to maintain compatibility with Nvidia....it's on them.
Reply With Quote
Reply

Tags
flicker, freesync, gsync, icue, monitor

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:44 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.