The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Notices

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 12-30-2019, 12:38 PM
jgranto jgranto is offline
Registered User
 
Join Date: Dec 2019
Posts: 1
POST ID # = 1029168
jgranto Reputation: 10
Default Virtuoso questions

I just got a Corsair Virtuoso SE headset and have run into two issues for which I am hoping you all can provide a solution.

First, what is the preferred dongle connection? Specifically, is USB 2.0 or USB 3.0 preferred, and is there a performance difference? Second, is a direct USB connection preferred, or is a USB hub acceptable?

Next, I have found that my system, which has no USB issues with any of the many other devices, including a wireless mouse and a wireless gamepad, runs into sporadic issues with the Virtuoso. I will finish using it in WIRELESS mode and turn it off by moving the switch to the wired mode. I come back to the system later on and turn on the headset (to use it wirelessly), only to find that it does not get discovered by the computer. This seems to occur in one of two different ways.

Situation #1: The headset pairs with the dongle fine (the light turns white), but the headset does not get discovered by the computer. Opening Device Manager does not show the device, the device is not seen in iCue, etc. Most of the time I can power off the headset (put it in wired mode) and move the dongle to a different port on a different USB bus and get it to appear. Sometimes this does not work and I have to reboot the computer (which is unacceptable).

Situation #2: The headset does not pair with the dongle (the light stays red) and the headset does not get discovered by the computer. In all other ways, including symptoms and solutions, this problem behaves like #1.

There is something going on between the Virtuoso and the PC that causes this problem. It is not a USB problem - again, I have multiple wired USB devices, as well as 1 - 2 other USB wireless (dongle) devices that work 100% fine - this problem never occurs to any of them. This problem is not systemic, it is specific to the Virtuoso.

I have two questions regarding this headset not getting discovered in wireless mode:
-Question 1: Is there anything that can be done from a setting perspective to prevent this from happening?
-Question 2: What can I do to discover the headset in such a situation? A reboot is NOT a solution. I am interested in a better solution - perhaps forcing the system to rescan for USB devices, etc. I have already tried a "devcon findall *" and it did nothing. I also tried Device Manager, right clicking "Sound, video, and game controllers", and selecting "Scan for hardware changes" - did not work. As I reported earlier, moving the dongle to a new USB slot often, but not always, works. I am interested in a solution that always works.

Thanks for your time!

P.S. I am running Windows 10 1909 with all current patches. I am also running the newest firmware (0.17.149 headset, 0.15.76 dongle). I have a K70 LUX RGB also using iCue, but the problem does not seem to be iCue-related, it seems more USB-related.
Reply With Quote


  #2  
Old 01-02-2020, 11:50 AM
c-attack c-attack is online now
Registered User
c-attack's PC Specs
 
Join Date: Jun 2014
Posts: 11,303
POST ID # = 1029500
c-attack c-attack Reputation: 116
Default

USB 2 vs 3 -> This should never matter for sound as the data transfer size if always going to be below USB 2 limits. Only people with raw uncompressed music files might hit this and someone working with those is not going to be using a headset.

It should work in any USB slot or hub. However, if there are issues staying connected through USB and it does better in USB 2 or 3 or hub or not, then that makes things fairly easy.

It looks like the dongle is dropping out from iCUE. This is a reported issue for some users. This may be related to the pairing issue as well. You may wish to start a Support Ticket with Corsair through the link above if you haven't already. That would pave the way for dongle or entire headset exchange if needed.

My interim suggestion is you try the Slipstream Beta version of iCUE below. It has different drivers for the dongle. There is one substantial caveat. The Slipstream Beta is from an earlier time the current public release of iCUE 3.23.66. This means your profiles created and being used in 3.23.66 will not work and you must completely uninstall them (delete settings) in order to load up the Beta. If you are on iCUE 3.22 or earlier, this will not be a problem. Also, if you only have the Virtuoso, this is not likely an issue. It is a much larger obstacle for those with large amount of keyboard and fan lighting.

https://forum.corsair.com/v3/showthread.php?t=191706
Reply With Quote


Reply

Tags
connectivity, virtuoso, wireless

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 06:52 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.