The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Hydro X Custom Cooling

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 08-08-2019, 11:54 PM
jrwininger jrwininger is offline
Registered User
 
Join Date: Jul 2017
Posts: 30
POST ID # = 1014152
jrwininger Reputation: 10
Default Hard tubing fittings question

I've assembled my first loop using the hard tubing. Everything seems fine...no leaks, etc. However, I can still see a bit of the green o-rings on the fittings. Is that normal? These should be hand tightened, correct?
Reply With Quote
  #2  
Old 08-09-2019, 03:16 AM
skyteam78 skyteam78 is offline
Registered User
skyteam78's PC Specs
 
Join Date: Jun 2019
Posts: 55
POST ID # = 1014166
skyteam78 Reputation: 10
Default

If no leaks you are good. Ad yes they should be hand tightened.
Reply With Quote
  #3  
Old 08-09-2019, 03:32 AM
Corsair GregX Corsair GregX is offline
Corsair Employee
 
Join Date: Apr 2019
Posts: 126
POST ID # = 1014168
Corsair GregX Reputation: 10
Default

Yes, it's normal that a bit of the green o-ring is visible.
Hand tightened and no leaks, all good.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:26 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.