The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > iCUE Software

Notices

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 01-08-2019, 11:29 AM
GasTheFanz GasTheFanz is offline
Registered User
GasTheFanz's PC Specs
 
Join Date: Sep 2018
Posts: 4
POST ID # = 988833
GasTheFanz Reputation: 10
Default Trouble with iCUE latest update for the K63 wireless KB and Darkcore SE wireless mous

The latest iCUE update has caused problems for my K63 wireless KB. My firmware is at v1.02 which there is a new version of V.3.07.

Once I updated to the new iCUE latest update, I then proceeded to update my firmware for the K63 KB. Problem is it stops right around 50%. Ive done this 3 times now with the same results. Once I reboot my version for the firmware goes back to v1.02 where as before the reboot the iCUE software says it has upgraded to the V3.07 even though it stops at 50% install.

Because of this problem, my settings for the "Enable LED auto shutoff" is bugged. Instead of just shutting down the LEDs, it shuts the whole KB down. I then proceed to wake it by clicking any button and the KB loses any type of function till I disconnect/reconnect the dongle! Where as before, it would just shutdown the LEDs and not the whole KB and worked just fine under the last version of the iCUE software!

As for the Darkcore SE wireless mouse. It seems to work ok. However, If i change the polling rate anything less than default (1000Hz/1 ms) the mouse loses disconnect but seems to reconnect with the click of the mouse. I keep the LEDs turned off all the time on the mouse as the battery never really lasts that long with them on. I also suspect that the "enable power saving mode" doesnt work properly or at all as my mouses battery life doesnt seem to change much, if at all, when using it.

I have reverted back to the old version of iCUE for now, but since I tried to update my firmware for the KB it still does the same thing under the old version. Ive even tried to re-install the firmware again under the old version and it still stops at 50%, disconnects and reverts back to v1.02.

Here is the hardware I am using at this time. the only other software I have running constantly in the BG is AntiVir, Killer Network Control Center, Raedon control center.

AMD FX6300 BBE (4.0GHz 6 core) AMD RX580X 8GB, 32GB Corsair Venegeance DDR3 1866, MSI FX990 G-Series MoBo, Seagate Barracuda 7200RPM 2TB HDD, Win 10 Home (fresh install and all up to date SP)

I have had nothing but trouble with this product since I purchased it several months ago. I suspect it has given me cancer and will be going to a doctor today to see if thats the case. If so, Corsair will have a lot more to figure out than why someone isnt properly making software correctly for these products. Its a shame really as Ive come to rely on Corsair for quality, but this has been nothing but a nightmare to straighten out and Im losing hope that it ever will. Hopefully, one day, Ill get what I paid for as it wasnt cheap by any means! Thanks?
Reply With Quote
  #2  
Old 01-25-2019, 06:30 PM
GasTheFanz GasTheFanz is offline
Registered User
GasTheFanz's PC Specs
 
Join Date: Sep 2018
Posts: 4
POST ID # = 991368
GasTheFanz Reputation: 10
Default

Well, my test results came back today.... I def have cancer. Thanks Corsair!
Reply With Quote
  #3  
Old 02-01-2019, 08:22 PM
freedoom freedoom is offline
Registered User
freedoom's PC Specs
 
Join Date: Feb 2019
Posts: 3
POST ID # = 992237
freedoom Reputation: 10
Default

I'm having the exact same problem. i updated my icue and firmware yesterday and today i'm back on my wireless membrane keyboard.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:24 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.