The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Cooling

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 10-18-2016, 10:25 AM
Ace6422 Ace6422 is offline
Registered User
Ace6422's PC Specs
 
Join Date: Oct 2016
Posts: 2
POST ID # = 875942
Ace6422 Reputation: 10
Default H115i Screw Holes in Radiator Possible RMA?

Somehow due to sheer stupidity and a lack of looking more carefully, I managed to use all 8 of the long screws to mount the radiator instead of the short screws, damaging a lot of the fins. I'm pretty certain that none of the water pipes were damaged in the radiator, but my cooling performance seems to be drastically affected, hitting 76C when running Prime95 on stock. I know this isn't normal based on this:
http://www.tweaktown.com/reviews/732...ew/index7.html
Is there any chance for me to successfully RMA the cooler, or do I have to suck it up and buy a new cooler?
Reply With Quote


  #2  
Old 10-18-2016, 01:55 PM
c-attack c-attack is offline
Registered User
c-attack's PC Specs
 
Join Date: Jun 2014
Posts: 9,228
POST ID # = 875984
c-attack c-attack Reputation: 107
Default

Run some other stress tests for comparison. You can't run P95 on auto voltage on Skylake. Use something less greedy, like Intel XTU, AIDA64, or Asus Real Bench. Even if you completely mangled all 8 screws threw the fins, that is only 1% of the radiator's surface area and on the fringe to boot. It should not affect performance.

You will get better CPU temps on any max load test with a fixed voltage. This is one of the key characteristics of Skylake chips.

Last edited by c-attack; 10-18-2016 at 07:13 PM.
Reply With Quote


  #3  
Old 10-20-2016, 09:32 PM
Ace6422 Ace6422 is offline
Registered User
Ace6422's PC Specs
 
Join Date: Oct 2016
Posts: 2
POST ID # = 876292
Ace6422 Reputation: 10
Default

Taking into consideration what you said, I did a bit more research and tweaked my settings so that I have LLC on at Level 4 and offset voltage keeping my CPU generally between 1.23v and 1.24v. Running Asus RB's stress test gets me temps of 54-61C with a water temp of about 29C. My temperatures don't really change regardless of what cooling profile I set in Corsair Link, so I think that it may be a problem with the connection to the CPU. When installing the cooler, I had to remove the cooler after installing it to screw in the fans (first build, noob mistake), including the pump. Would this screw up the thermal paste at all?

Thank you!
Reply With Quote


  #4  
Old 10-20-2016, 10:16 PM
c-attack c-attack is offline
Registered User
c-attack's PC Specs
 
Join Date: Jun 2014
Posts: 9,228
POST ID # = 876294
c-attack c-attack Reputation: 107
Default

What kinds of temps were you expecting? I don't see a problem with those numbers.

Remember the fans help remove heat from the water (H115i Temp). You can't directly affect CPU temps, other than to lower the baseline they start from (the H115i Temp again). If it's 22C in your room and your water temp is 29C, the most you could ever reduce CPU temps at any fan speed is 7C. For that to happen, you would also have to keep your case internal ambient temp the same as the room temperature. That's rather difficult in itself. The difference between the water temperature and the actual CPU core temps is down to the thermal conductivity between the CPU/heat spreader/TIM/cold plate sandwich (a fixed rate) and the voltage being applied (very dynamic). For most people on recent CPUs, this is the limiting factor, not the amount of heat the cooler is able to dissipate.

If you somehow botched the TIM spread when installing, your idle temps would be all over the place. Not just high, but also almost random or nonsensical. I suspect this is not true, otherwise you would not have been able to finish Real Bench and certainly not P95.
Reply With Quote


Reply

Tags
cooler, damage, rma

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 12:46 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.