The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 10-20-2014, 01:22 AM
killercola killercola is offline
Registered User
 
Join Date: Oct 2014
Posts: 6
POST ID # = 736720
killercola Reputation: 10
Default Corsair 2100 Turning off immediately

I just recentley replaced my vengeance 2100, and now this new one. Doesn't charge, or i am guessing? Charging light does not come on. Then when the headset does come on there is a buzzing sound and immediately cuts off. When the charger is unplugged it comes on with a very dim blue light and cuts off again. Should i just replace the headset for the second time? or is there any fix?
Reply With Quote


  #2  
Old 10-21-2014, 02:18 AM
killercola killercola is offline
Registered User
 
Join Date: Oct 2014
Posts: 6
POST ID # = 736945
killercola Reputation: 10
Default

removed post

Last edited by killercola; 09-07-2015 at 05:45 PM.
Reply With Quote


  #3  
Old 10-21-2014, 10:29 PM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 19,344
POST ID # = 737169
Toasted Toasted Reputation: 108
Default

Have you tried a different USB charging cable (MicroUSB) and USB port?

If it still does not charge, contact customer service and tell them the replacement headset is faulty.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:49 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.