The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 04-13-2017, 05:36 PM
t1nusk4 t1nusk4 is offline
Registered User
 
Join Date: Apr 2017
Posts: 2
POST ID # = 899191
t1nusk4 Reputation: 10
Default Headset not working with 15063.138 Win 10 Build

Hi,

first time post on this forum, please help.

Yesterday I updated to the newest windows build
https://technet.microsoft.com/en-us/...ease-info.aspx

Since then, I can't get my Corsair wireless headset to work. I googled the issue, most people seemed to have problem with transition from Win8 to Win 10 (I didn't experience that). I reinstalled all drivers, restarted a million times, no change. Any ideas how to fix this?

My HS model:
http://www.corsair.com/en-us/vengean...gaming-headset

Thanks
Reply With Quote


  #2  
Old 04-14-2017, 09:21 AM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 19,344
POST ID # = 899273
Toasted Toasted Reputation: 108
Default

What error are you seeing/problem you are experiencing that is prevnting the headset from working?
Reply With Quote


  #3  
Old 04-14-2017, 11:27 AM
t1nusk4 t1nusk4 is offline
Registered User
 
Join Date: Apr 2017
Posts: 2
POST ID # = 899304
t1nusk4 Reputation: 10
Default

Solved. I let the headset battery to drain completely, recharged, turned PC on/off, and today it's working again. Life is a mystery.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 07:25 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.