The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 04-28-2019, 10:46 AM
Soliex Soliex is offline
Registered User
 
Join Date: Jun 2018
Posts: 3
POST ID # = 1002824
Soliex Reputation: 10
Default M65 RGB Elite, Left click issues

This M65 RGB Elite is only 5 months old and my left click on the mouse is having issues. I have to press firmly on the left click to get it to register when it used to work whenever I heard the mouse click.

I can hear the click when I lightly press the left click side of the mouse but it does not register, this is driving me nuts when playing games and its really impacting my ability to play. The right click button will register every time I hear the mouse click but the left side does not.

I'm not clicking it in a weird or strange spot either, I am clicking towards the middle of the left click area between the mouse wheel and up arrow in the middle of the mouse.

Has anyone experienced this before, is there something I can do to fix it or should I open a support ticket? Thanks.
Reply With Quote


  #2  
Old 05-29-2019, 12:27 AM
nunFalco nunFalco is offline
Registered User
 
Join Date: Jan 2017
Posts: 1
POST ID # = 1006066
nunFalco Reputation: 10
Default

I am having the same problem ¿do you find any solution?
Reply With Quote


  #3  
Old 05-29-2019, 01:09 AM
Saisin Saisin is offline
Registered User
 
Join Date: May 2019
Posts: 1
POST ID # = 1006069
Saisin Reputation: 10
Default

Same here my left click not working. any solutions?
Reply With Quote


  #4  
Old 05-31-2019, 07:18 AM
chonusftw chonusftw is offline
Registered User
 
Join Date: May 2019
Posts: 1
POST ID # = 1006379
chonusftw Reputation: 10
Default

im having exactly same issue since last iCue update with a Glaive RGB mouse.
Reply With Quote


  #5  
Old 06-03-2019, 05:57 AM
KaiLono KaiLono is offline
Registered User
 
Join Date: Jun 2019
Posts: 1
POST ID # = 1006695
KaiLono Reputation: 10
Default

Im having the same issues since i made de actualization of the icue software. the left buttons stop working
Reply With Quote


  #6  
Old 06-03-2019, 06:42 PM
Corsair Calico Jack's Avatar
Corsair Calico Jack Corsair Calico Jack is offline
Corsair Employee
 
Join Date: Oct 2016
Posts: 578
POST ID # = 1006800
Corsair Calico Jack Reputation: 10
Default

It's either a hardware issue or a driver issue. If it's iCUE, doing this will correct it: https://support.corsair.com/app/answ...id/77/kw/clean

If that doesn't work, create a ticket and we can look into replacing the mouse.
Reply With Quote


  #7  
Old 06-10-2019, 07:45 PM
SrRealist SrRealist is offline
Registered User
 
Join Date: Dec 2014
Posts: 10
POST ID # = 1007575
SrRealist Reputation: 10
Default

also started noticing this seeming out of nowhere. ive had this issue with previous m65s, this is my first elite.

really a damn shame, the mouse feels like a dream, save for remarkably unreliable responsiveness all of the sudden.
Reply With Quote


  #8  
Old 06-13-2019, 12:27 AM
KOKOtm KOKOtm is offline
Registered User
 
Join Date: Jun 2016
Posts: 14
POST ID # = 1007829
KOKOtm Reputation: 10
Default

This ****ing left click annoyance... had it with my old M65 pro, this went away alone... then I had it with my new Elite. I got a replacement through corsair support for it (great support btw. but I would prefer a flawless product). Left click issues happens a lot with Corsair on multiple products. I currently have the Ironclaw Wireless with no problems... lets see how long. ;-)
Reply With Quote


  #9  
Old 06-20-2019, 09:23 AM
Low Fidelity Low Fidelity is offline
Registered User
 
Join Date: Jun 2019
Posts: 2
POST ID # = 1008626
Low Fidelity Reputation: 10
Default

I'm having the same issues suddenly with my m65 Elite left clicking as well. I can feel the click. I can hear the click, but the click doesn't register unless I click harder.

The link that Corsair Calico Jack provided doesn't work.

Could someone provide instructions for a clean install of the software?

Thanks
Reply With Quote


  #10  
Old 06-20-2019, 09:47 AM
Low Fidelity Low Fidelity is offline
Registered User
 
Join Date: Jun 2019
Posts: 2
POST ID # = 1008631
Low Fidelity Reputation: 10
Default

Downloaded latest version of iCUE from corsair.

Uninstalled previous version of iCUE.

Shut down windows 10.

Restarted windows 10.

Installed latest version of iCUE.

Restarted windows 10.

Noticed that I was experiencing left click issues after I had uninstalled iCUE and was shutting down the machine. Noticed that I was also experiencing left click issues before installing software.

And I'm sill having left click issues. Mouse is 6 months old.
Reply With Quote


  #11  
Old 06-22-2019, 02:57 PM
marsrunner marsrunner is offline
Registered User
marsrunner's PC Specs
 
Join Date: Jun 2019
Posts: 1
POST ID # = 1008931
marsrunner Reputation: 10
Default

I am also having issues. I entered a request (#2000450653) 7 days ago asking for an older firmware to see if that might fix it, but have received no answer. I doubt they will honor a return since I did not buy it from them, and I can't return it to the place I bought it because it is outside the return window. I've only had this thing since February. I tried my wife's Sabre RGB mouse, and it works fine.

Very irritated with this issue, and the lack is response makes it even more irritating. This mouse should not stop working like this from a mechanical standpoint after such a short time.
Reply With Quote


  #12  
Old 06-25-2019, 03:02 AM
bruzor bruzor is offline
Registered User
bruzor's PC Specs
 
Join Date: Jun 2019
Posts: 1
POST ID # = 1009233
bruzor Reputation: 10
Default

Not sure it will help. But just came to say I'm having the same issue. So so so frustrating. Crosshair on someones head in CS:GO and no click.. then i get killed.

I've been reading about this issue and it seems it goes all the way back to almost 2016 on several different mice. This is also the second M65 RGB Elite I've had. The first one lasted about a year and then completely stopped working mid match. No optical sensor, no RGB, no clicks. nothing. This one I have had since about December of 2018 and I've had the left click issue for right at about 3 months now.

Why is this an issue with so many customers mice and how is it that this hasn't been addressed yet Corsair? So many of my components are Corsair.... however I'm starting to lose faith. :(
Reply With Quote


  #13  
Old 07-19-2019, 05:55 PM
MitchMeister03 MitchMeister03 is offline
Registered User
MitchMeister03's PC Specs
 
Join Date: Jan 2019
Posts: 3
POST ID # = 1011838
MitchMeister03 Reputation: 10
Default

Same issue with my m65 elite. I opened a ticket on Monday and have had no response to it yet. Really disappointing considering how much I love the mouse. I have so much corsair gear, it would suck to have to purchase a different mouse. Hopefully they respond soon, or I'll have to buy a different mouse.
Reply With Quote


  #14  
Old 07-24-2019, 08:15 AM
YeS_987 YeS_987 is offline
Registered User
 
Join Date: Jul 2019
Posts: 1
POST ID # = 1012331
YeS_987 Reputation: 10
Default

I don´t have a problem with the left click but my sensor doesn´t work a all. at first it was completely normal and then it started to stop registering my movement. after that the controls invertied to the opposite directions and now it doesn´t wor at all.
Does someone have a solution?
Reply With Quote


  #15  
Old 08-14-2019, 04:52 PM
Stud_Beefpiler Stud_Beefpiler is offline
Registered User
Stud_Beefpiler's PC Specs
 
Join Date: Aug 2019
Posts: 4
POST ID # = 1014665
Stud_Beefpiler Reputation: 10
Default

I got m65 elite in June and just opened a ticket with support on it yesterday for this exact reason.

The issue is very reminiscent of one I experienced using a standard mouse for years(and years). The button simply wore out and required extra effort to get it to register the click.

This one is now behaving almost identically to the standard mouse that I wore out. Cleared the device storage. Forced a fresh firmware install. Performed a soft reset.

Seems like a mechanical issue to me, but what do I know?
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:17 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.