The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 09-19-2018, 07:33 AM
Zogito Zogito is offline
Registered User
 
Join Date: Sep 2018
Posts: 3
POST ID # = 973390
Zogito Reputation: 10
Question Strange issue with keyboard

Hello everyone.I have been experiencing some issues lately with my K70 RGB.Th problem is that i have plugged both usb in a usb3.1 port and when i boot my pc it is stuck on a black screen forever.When i plug out my keyboard i am on my desktop in no time!After plugging in again my keyboard everything is normal colors are fine and it is working perfectly.My pc is brand new with mobo z370 msi m5 and i5 8600k.I have forced update the same firmware on my keyuboard also tried the firmware reset with the escape button.Finally polling rate is set to 1ms.Thank you in advance for your time and help!
Reply With Quote


  #2  
Old 09-19-2018, 04:28 PM
Zogito Zogito is offline
Registered User
 
Join Date: Sep 2018
Posts: 3
POST ID # = 973446
Zogito Reputation: 10
Default

Update : K70 has two usb on the end of the cord.I plugged out the one of them and my pc boots in no time.Question though...What am i losing with the one of two usb that is unplugged?Why does it have two usb anyways??
Reply With Quote


  #3  
Old 09-19-2018, 06:00 PM
StrangeGeek StrangeGeek is offline
Registered User
 
Join Date: Apr 2018
Location: On Earth along with 7.5B people
Posts: 91
POST ID # = 973457
StrangeGeek Reputation: 10
Default

Quote:
Originally Posted by Zogito View Post
Update : K70 has two usb on the end of the cord.I plugged out the one of them and my pc boots in no time.Question though...What am i losing with the one of two usb that is unplugged?Why does it have two usb anyways??
It only needs two USB ports if you are using USB 2.0. If the main connector (the plug with the image of a keyboard on it) is plugged into a 3.0 or 3.1 port, then there is no need to use the second.
Reply With Quote


  #4  
Old 09-19-2018, 06:24 PM
Zogito Zogito is offline
Registered User
 
Join Date: Sep 2018
Posts: 3
POST ID # = 973465
Zogito Reputation: 10
Default

OK so probs we found our problems and that was all about it.Thank you!
Reply With Quote


  #5  
Old 09-20-2018, 10:21 PM
StrangeGeek StrangeGeek is offline
Registered User
 
Join Date: Apr 2018
Location: On Earth along with 7.5B people
Posts: 91
POST ID # = 973612
StrangeGeek Reputation: 10
Default

Quote:
Originally Posted by Zogito View Post
OK so probs we found our problems and that was all about it.Thank you!
Your welcome.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 12:22 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.