The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Power Supplies

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 09-07-2015, 08:48 AM
Braxos Braxos is offline
Registered User
Braxos's PC Specs
 
Join Date: Jun 2013
Location: Germany
Posts: 171
POST ID # = 805409
Braxos Reputation: 10
Default Ax1200i power cord issues

Hi

The past days I was swapping in and out a 980 ti strix, coil whine and not stable clock speed on games 900-1350, there I noticed that the power cord isn't sitting well on the psu and every time I move a bit the case I hear a electric noise, as the cable isn't making full contact on the socket. I push it I removed it and refit it nothing makes any difference every time I move the case I hear the noise. As the socket can't keep the power cord in place and it gets loose from the weight of the cord.
Is it a cord issue or socket issue?

I will post a video later tonight.
Reply With Quote


  #2  
Old 09-07-2015, 12:58 PM
jonnyguru jonnyguru is offline
PSU GUY
jonnyguru's PC Specs
 
Join Date: Feb 2003
Posts: 2,883
POST ID # = 805437
jonnyguru jonnyguru Reputation: 179
Send a message via ICQ to jonnyguru Send a message via MSN to jonnyguru Send a message via Yahoo to jonnyguru Send a message via Skype™ to jonnyguru
Default

It's a standard power cord. You don't have another one to try?
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 08:22 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.