The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > iCUE Software

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 10-11-2019, 03:18 PM
SoggyBread SoggyBread is offline
Registered User
SoggyBread's PC Specs
 
Join Date: Oct 2019
Posts: 3
POST ID # = 1020998
SoggyBread Reputation: 10
Default won't open

I have been looking at every single post for this and still don't have a solutions i have updated all my drivers reinstalled a thousand times and still cant get it to open. I am using v3.20.80

Last edited by SoggyBread; 10-11-2019 at 03:58 PM.
Reply With Quote
  #2  
Old 10-14-2019, 01:27 PM
Takemikazuch Takemikazuch is offline
Registered User
 
Join Date: Oct 2019
Posts: 1
POST ID # = 1021282
Takemikazuch Reputation: 10
Default

I too was having issues with icue 3.20.80. Uninstalled, reinstalled, repair, admin mode, the works. Finally I just rolled back to 3.18.77 and I'm back in business. I would recommend you do the same, as well as anyone else having issues with this version.
Reply With Quote
  #3  
Old 10-14-2019, 03:52 PM
nowcontrol's Avatar
nowcontrol nowcontrol is offline
spazclart
nowcontrol's PC Specs
 
Join Date: Nov 2015
Location: LDN/UK
Posts: 31
POST ID # = 1021289
nowcontrol Reputation: 12
Default

Try this out...
Quote:
Originally Posted by nowcontrol View Post
1. Uninstall 3.XX and delete folder 'Users/yourname/AppData/Roaming/Corsair' then reboot.

2. Download and install the latest iCUE (3.20) then reboot.

If that doesn't work then I don't know what will.
__________________

Reply With Quote
  #4  
Old 10-14-2019, 08:00 PM
Dex23633 Dex23633 is offline
Registered User
Dex23633's PC Specs
 
Join Date: Oct 2019
Posts: 8
POST ID # = 1021299
Dex23633 Reputation: 10
Default

Quote:
Originally Posted by Takemikazuch View Post
I too was having issues with icue 3.20.80. Uninstalled, reinstalled, repair, admin mode, the works. Finally I just rolled back to 3.18.77 and I'm back in business. I would recommend you do the same, as well as anyone else having issues with this version.
Ive try roll back but nothing work for me sadly i cant get firmware update since i have major upgrade such as new motherboard etc

it really p***ed me off big time and the stress
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 03:43 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.