The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > iCUE Software > iCUE SDK

Notices

 
 
Thread Tools Search this Thread Rate Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 07-29-2018, 11:48 PM
MichaelXF MichaelXF is offline
Registered User
MichaelXF's PC Specs
 
Join Date: Jul 2018
Posts: 6
POST ID # = 966152
MichaelXF Reputation: 10
Question Set color of Lighting Node Pro devices?

I currently have the following code:
Code:
colors[j].ledId = static_cast<CorsairLedId>(200+j);
which I later use to
Code:
if (CorsairSetLedsColorsBufferByDeviceIndex(i, leds, colors)) {
    std::cout << "Should be BLUE rgb(0,0,255)?";
} else {
    const CorsairError error = CorsairGetLastError();
    std::cout << "It didn't work see " << toString(error) << ";";
}
full code: https://hastebin.com/jazezuvemo.cpp

But it wont work, yes the SDK is fully initialized (hopefully), my guess is the CorsairLedId are wrong? There is little documentation of the ids, im guessing CLD_C1_1 = 200 is the "starting point"? Anyone know the ledIds for the Lighting Node Pro (preferably channel 1)?

Here is my output of the code: https://hastebin.com/olexesoyiz.cs
Reply With Quote
 

Tags
corsair, help me, node pro, sdk

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:54 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.