The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Power Supplies

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 02-09-2018, 05:09 PM
hodgey98 hodgey98 is offline
Registered User
hodgey98's PC Specs
 
Join Date: Feb 2018
Posts: 1
POST ID # = 939919
hodgey98 Reputation: 10
Question HX850i Issues

Hi,

I recently bought a HX850i PSU and fitted it myself. I am currently having an issue where my rear USB 2.0 ports don't seem to be working. I am trying to connect an Xbox controller and Logitech headset to them which was never a problem on my old PSU.

It is worth mentioning that everything else seems to be functioning normally. The headset makes a popping noise every few seconds and the controller lights up intermittently but neither will work properly.

If I plug my Keyboard/Mouse into these ports they do not work either.

Any help would be greatly appreciated.

Thank you.
Reply With Quote


  #2  
Old 02-15-2018, 02:33 PM
Corsair Mike's Avatar
Corsair Mike Corsair Mike is offline
Corsair Employee
 
Join Date: Dec 2017
Posts: 151
POST ID # = 940769
Corsair Mike Reputation: 10
Default

This sounds like a driver issue or a motherboard fault. I would try reinstalling usb drivers from your motherboard's website.
Reply With Quote


Reply

Tags
hx850i, issue, problem, psu, usb

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 06:32 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.