The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 31 votes, 5.00 average. Display Modes
  #1  
Old 11-09-2013, 03:59 PM
Lushbits Lushbits is offline
Registered User
 
Join Date: Nov 2013
Posts: 1
POST ID # = 682060
Lushbits Reputation: 10
Thumbs up (SOLVED) Crackling sound in headset - Vengeance 2100

Hi everyone!

I just got myself the new Vengeace 2100 headset the other day. I was a bit disappointed at first, because there was sort of a crackling sound in the headset, specially notable on the ring tone and conversation in Skype (that frequency i guess).

After searching around on the web I found some threads, some even local in Sweden that had users with the same issue, some even returned them straight away to the store.

Now, I fiddled around a bit the sound settings in windows and found out that changing from CD-quality to DVD-quality (44100 Hz to 48000 Hz) TOTALLY GOT RID of the crackling sound. This might be a no-brainer for some, but I guess there are more like me out there who didn't know this.

This is how you do it:

1: Control Panel (icons) > Sound > Playback
2: Click properties on the Corsair
3: Head to the advanced tab
4: Choose 16 bits, 48000 Hz (DVD quality)

you will get a warning that this might interfere with another program (I guess the Corsair drivers, but I just ignored that and hit OK anyways).

Good luck!

/Lush
Reply With Quote


  #2  
Old 11-16-2013, 10:48 AM
Minoza Minoza is offline
Registered User
Minoza's PC Specs
 
Join Date: Nov 2013
Location: Croatia
Posts: 3
POST ID # = 682978
Minoza Reputation: 10
Default

Thank you! This helped me as well, I was getting desperate in searching for a solution.
Reply With Quote


  #3  
Old 01-07-2014, 11:39 AM
razl2508 razl2508 is offline
Registered User
 
Join Date: Jan 2014
Posts: 1
POST ID # = 691366
razl2508 Reputation: 10
Default

Omg thank you so much dude, I made this account just to thank you xD so thank you so much!!! :D
Reply With Quote


  #4  
Old 01-14-2014, 12:25 AM
SlySonders SlySonders is offline
Registered User
 
Join Date: Jan 2014
Posts: 7
POST ID # = 692520
SlySonders Reputation: 10
Default

This did not work for me. Every time I move my head, the sound crackles and pops and even cuts out completely, and the USB starts to flash as if they lost connection. Is there any way to fix this?
Reply With Quote


  #5  
Old 01-14-2014, 03:25 AM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 19,344
POST ID # = 692536
Toasted Toasted Reputation: 108
Default

How far away is the dongle from the headset?
Are there any wireless devices near the dongle and headset?
Reply With Quote


  #6  
Old 01-17-2014, 05:43 PM
SlySonders SlySonders is offline
Registered User
 
Join Date: Jan 2014
Posts: 7
POST ID # = 693127
SlySonders Reputation: 10
Default

Its about a foot away from me.

It started working fine for a couple of days and now it started doing the same thing.
The only wireless device is my phone. This 2100 is a replacement to my 2000 which never had this issue. My phone was always near me.
I left my phone in another room and the problem persists.
If I am any distance past 1-2 feet from the dongle, the headset looses connection completely. Sometimes I have to hold the dongle right up to the headset for me to get any sound.
Reply With Quote


  #7  
Old 01-18-2014, 02:27 AM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 19,344
POST ID # = 693226
Toasted Toasted Reputation: 108
Default

It might be a problem with the dongle.

Request an RMA and explain your issue.
Reply With Quote


  #8  
Old 01-27-2014, 08:47 PM
SlySonders SlySonders is offline
Registered User
 
Join Date: Jan 2014
Posts: 7
POST ID # = 694712
SlySonders Reputation: 10
Default

So here's the problem. In the ticket I made for the original 2000, they asked me how my 2100 is going and for the tracking number. I told them that the 2100 is not going well and explained them the situation. I also gave them the tracking number. After that I have not gotten any responses since the 18th!!! (the 2000 has been delivered per UPS) Its like they got their product so screw me.

This is getting extremely frustrating as it seems I cannot open another express RMA until they close this ticket. When I call in all I get are voice mail's and zero call backs. I'm stuck with a non working headset and absolutely ZERO response from corsair!!! I'm fed up with this ***** and wanting my money back if this doesn't get resolved PRONTO! I'm a paying customer and should not be treated like this!
Reply With Quote


  #9  
Old 01-27-2014, 09:41 PM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 19,344
POST ID # = 694727
Toasted Toasted Reputation: 108
Default

Post your ticket # here.
Reply With Quote


  #10  
Old 01-28-2014, 03:54 PM
SlySonders SlySonders is offline
Registered User
 
Join Date: Jan 2014
Posts: 7
POST ID # = 694847
SlySonders Reputation: 10
Default

6374898
6345772

Corsair just replied saying that its a problem with the dongle and they will send a new dongle to me thankfully.

That's all I wanted, I just wanted some love!!! lol
Reply With Quote


  #11  
Old 01-28-2014, 10:46 PM
DRTauli DRTauli is offline
Registered User
DRTauli's PC Specs
 
Join Date: Jan 2014
Location: Baguio, Philippines
Posts: 7
POST ID # = 694887
DRTauli Reputation: 10
Send a message via Yahoo to DRTauli Send a message via Skype™ to DRTauli
Default

Thanks this worked for me.
Reply With Quote


  #12  
Old 02-06-2014, 05:48 PM
SlySonders SlySonders is offline
Registered User
 
Join Date: Jan 2014
Posts: 7
POST ID # = 696124
SlySonders Reputation: 10
Default

Looks like my USB itself had the problem. Was replaced and now everything work fine.
Reply With Quote


  #13  
Old 02-12-2014, 01:07 PM
Corsair Henry's Avatar
Corsair Henry Corsair Henry is offline
Corsair Employee
Corsair Henry's PC Specs
 
Join Date: Oct 2013
Location: Corsair HQ
Posts: 1,403
POST ID # = 696902
Corsair Henry Reputation: 14
Default

Quote:
Originally Posted by SlySonders View Post
Looks like my USB itself had the problem. Was replaced and now everything work fine.
Glad to hear that the replacement USB dongle fixed the issue
Reply With Quote


  #14  
Old 12-25-2014, 08:37 PM
crasucks crasucks is offline
Registered User
crasucks's PC Specs
 
Join Date: Dec 2014
Posts: 1
POST ID # = 749036
crasucks Reputation: 10
Default

Quote:
Originally Posted by SlySonders View Post
Its about a foot away from me.

It started working fine for a couple of days and now it started doing the same thing.
The only wireless device is my phone. This 2100 is a replacement to my 2000 which never had this issue. My phone was always near me.
I left my phone in another room and the problem persists.
If I am any distance past 1-2 feet from the dongle, the headset looses connection completely. Sometimes I have to hold the dongle right up to the headset for me to get any sound.
I have a similar problem. I just got the 2100H for Christmas, however it works like crap with respect to the mic. If I am further than 1-2 feet away from the USB dongle it completely drops out, but even close to the dongle is on and off.

As I just got this for Christmas, (even though it was most likely ordered 2 months ago) I think considering all the problems with this headset I might want to just get my money back.

However I guess I will have to go through support first.
Considering the 1000's of posts about the problems with this product, I would seriously expect a company that wanted to exist years from now, rather than the typical accountant run company that only looks 1 quarter ahead, to actually test their product before releasing it.

I will post my results on this issue.
I tried the headset on a different computer with Win 7 and Win 8.1, both had problems.
Reply With Quote


  #15  
Old 05-04-2015, 10:51 AM
SioN_Chris_Dawn SioN_Chris_Dawn is offline
Registered User
 
Join Date: May 2015
Posts: 1
POST ID # = 777224
SioN_Chris_Dawn Reputation: 10
Default

Amazing. Thank you so much!
Reply With Quote


Reply

Tags
headset, quality, sound problem, vengeance 2100, wireless

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 03:51 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.